Vnc won't work without jetson connected to monitor

Jetson nano 4gb Developer kit
jetpack 4.5.1

Followed instructions in this link

additionally also had to add: /usr/lib/vino/vino-server in startup applications

In my laptop i installed vncviewer and gave ip address of my jetson connected to same network.

I can only see Nvidia logo

But when i connect jetson with my monitor thorugh hdmi, i can also see the desktop of jetson on my vnc viewer in my laptop

but i want to see it without connecting monitor to jetson. Can someone help me?

The L4T-README volume will mount on the other computer, including files such as README-vnc.txt.

This readme file has below content.

Setting the Desktop Resolution

The desktop resolution is typically determined by the capabilities of the
display that is attached to Jetson. If no display is attached, a default
resolution of 640x480 is selected. To use a different resolution, edit
/etc/X11/xorg.conf and append the following lines:

Section "Screen"
   Identifier    "Default Screen"
   Monitor       "Configured Monitor"
   Device        "Tegra0"
   SubSection "Display"
       Depth    24
       Virtual 1280 800 # Modify the resolution by editing these values
   EndSubSection
EndSection

i tried this,

and unfortunately, the situation is the same.

i connect jetson through vnc, i see only nvidia logo

but when i connect the jetson with monitor through hdmi i can see desktop both in monitor and on vnc

thats how my xorg.conf file looks like…

autostart

gdm3 conf

also i did reboot after making above changes

What is the result when you use xrandr command ?

can’t open display

After using “export DISPLAY=:0” ?

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 16384 x 16384
HDMI-0 disconnected primary (normal left inverted right x axis y axis)
DP-0 disconnected (normal left inverted right x axis y axis)

i was hoping it will work, so i did a reboot now.

and xrandr now gives “can’t open display”

and still vnc shows only nvidia logo when jetson is connected without monitor

May need to try something like this:

this makes it worse,

now i can’t see anything either on monitor or on vnc

Then maybe you can try other vnc server suggested by other users. There are lots of posts on the forum.