headless VNC access without attached monitor

I’m trying to wade through many postings about how to set up a nano for headless access without an attached monitor. Some of these postings contradict one another.

It’s well documented that vino will not run at boot time if a monitor is not attached. Attaching a monitor long-term is not an option for me due to its location in the house.

I tried using an HDMI dummy plug that is supposed to emulate a monitor to ‘trick’ the nano into launching vino, but that did not work: after boot, the vino server is not running. Perhaps my device is not working (though others claim that this method works), or I’ve not set it up right.

I also tried tightvnc, which did not work at all.

Finally, I got x11vnc to work - sort of - I get a gnome window, but it’s a stripped down version of what I see when physically attaching the monitor, and interface is very awkward.

In each case I’ve tried to follow recommend procedures for startup files and gnome settings.

Perhaps the NVIDIA folks can say what the right procedure is.


Unfortunately, if there is no monitor case, then VNC cannot work.
You could try to use RDP (remote desktop protocol) application and it should work. However, EGL seems not able to run with rdp backend. Thus, if you want to render something by using EGL, it would not work.

Well, in fact, yes, I now find that you can get VNC vino to work in headless mode.

First, you buy an HDMI “dummy” dongle like this one:


At boot time, the OS thinks a full HDMI monitor is attached.

You must then configure gnome to log you in without a password.

I would follow these two narratives:

Get vino set up properly:


To enable login without a password:


When I do this, I’m essentially sharing the session with myself (but I’m the only user anyway), with the full gnome desktop that I would get with a real, physical monitor, not some crippled version.

So now the Jetson nano joins my other SoCs: Raspberry Pis and Odroid N2 as accessible in full desktop mode when I need it.

1 Like