"raspi-config" like configuration setting command in jetson nano

Is there a command like “raspi-config” in jetson nano?
I do like to change nano’s configuration more easily like raspi-config in Raspberry Pie

Hi fortis342,

Sorry that there is no such tool in our software package.

What function do you need?

Sorry for late reply.
There is a problem with headless connection using VNC.
The size of the vnc screen is too small.
Unknown error when entering “System Settings -> Displays”
Is there a way to change the default size of the screen output when connecting to vnc?

https://postechackr-my.sharepoint.com/:f:/g/personal/sunghoon1kim_postech_ac_kr/EnD6OtQw-wpMvxfgYFfAruQB79wBjNz31G86UAW1Z8Jy3A?e=hEjjJP

The VNC server supports dynamically changing display resolution to support multiple monitor sizes. To enable support add the -randr option to ~/.vnc/config.d/Xvnc ( Create the file if it is not existing) with the VNC display sizes to support. For example:

RandR=1600x900,1920x1080,3840x2160,1920x1200,1408x792,800x600

Then,

use something like

xrandr -s 1920x1080 to change the resolution.

Actually I didn’t hit such issue. What is your vnc server setup and client?

Thank you WayneWWW.

There are no .vnc folders so I created ~/.vnc/config.d/Xvnc file and write RandR=1600x900,1920x1080,3840x2160,1920x1200,1408x792,800x600

then $ chmod +x Xvnc for execute permission.

But, when type xrandr -s 1920x1080 , RandR extension missing error occurs.

Actually, I followed vnc setting instructions as follows at the first setting.

https://blog.hackster.io/getting-started-with-the-nvidia-jetson-nano-developer-kit-43aa7c298797
Gnome Vino

I’m using RealVNC in my host computer.

Thanks.

Have you followed up our document? It would show up on your host when you are using usb device mode.

Hi fortis342,

You can use below steps to setup vnc:

Installing the VNC Server
$ sudo apt update
$ sudo apt install vino

Enabling the VNC Server
# Enable the VNC server to start each time you log in
sudo ln -s ../vino-server.service /usr/lib/systemd/user/graphical-session.target.wants

# Configure the VNC server
gsettings set org.gnome.Vino prompt-enabled false
gsettings set org.gnome.Vino require-encryption false

# Set a password to access the VNC server
# Replace thepassword with your desired password
gsettings set org.gnome.Vino authentication-methods "['vnc']"
gsettings set org.gnome.Vino vnc-password $(echo -n 'thepassword'|base64)
***"thepassword" setting the password that you want.

# Reboot the system so that the settings take effect
sudo reboot

After boot up and using ‘ifconfig’ to check eth0 ip address
Open VNC and enter the ip address and password to login.

You can check more detail from ‘README-vnc’ document.

how to undo this above commands because after executing these commands my os has lost most of its graphics.its harder to use.
i would rather not use vnc. can you please specify the steps required for that

Hi im.bharma,

After enable vino-server, the graphics still exist.
You can use below command to stop it:

$ sudo systemctl stop vino-server

If you want clean image, suggest you can flash image.