Ubuntu Internal error when selecting desktop sharing in settings.

I would like an alternative to vino as it’s not feasible to attach a monitor to my nano, so I need a headless virtual desktop.

I tried this:

sudo apt install tigervnc-standalone-server tigervnc-xorg-extension -y

…but apt found no such packages.

Elsewhere there’s a blog that says I could also install xrdp:

…but I get the same message (not found).

Is a repository where I can retrieve either of these?

Hello xtz465,

You might need to add the Universe repository first:

sudo apt-add-repository universe
sudo apt update

and then try running your tigervnc options again.

Good luck,


I get this:

% sudo apt-add-repository universe
‘universe’ distribution component is already enabled for all sources.

…and this:

% sudo apt update

part of long output:

Err:19 Index of /ubuntu-ports bionic-updates Release
Cannot initiate the connection to ports.ubuntu.com:80 (2001:67c:1360:8001::22). - connect (101: Network is unreachable)
Err:20 http://international.download.nvidia.com/jetson/repos/t210 r32 Release
Cannot initiate the connection to international.download.nvidia.com:80 (2606:2800:21f:3aa:dcf:37b:1ed6:1fb). - connect (101: Network is unreachable)
Err:21 Index of /ubuntu-ports bionic-backports Release
Cannot initiate the connection to ports.ubuntu.com:80 (2001:67c:1360:8001::22). - connect (101: Network is unreachable)
Err:22 Index of /ubuntu-ports bionic-security Release
Cannot initiate the connection to ports.ubuntu.com:80 (2001:67c:1360:8001::22). - connect (101: Network is unreachable)

Is this a problem? Not sure what to do about it.

That looks like you might have some issues with your network, are you behind a proxy or perhaps your DNS isn’t configured correctly? It seems to resolve to an IPv6 address, perhaps that can also influence your results

I’ve been running an ad blocker through a Raspberry Pi for half a year or so. I don’t encounter many blocked sites that I actually need, and in any event there’s a whitelist for exceptions. I added ports.ubuntu.com to that list, but apt stilll doesn’t connect, even though I can navigate to that site in a browser.

In any event I reconfigured the router to bypass the ad blocker, and I’m getting the same (non) results.

I also have 4 Raspberry Pis running stretch and an Odroid N2 running Ubuntu, and I’ve never encountered this problem (apt update) with any update with them through the ad blocker.


I can ping ports.ubuntu.com successfully from the Odroid N2 running Ubuntu 18.04.

If ping ports.ubuntu.com from the nano, I get “destination host unreachable”

So there is clearly a setting on the nano that has to be changed.

I tried editing /etc/sysctl.conf and then

sudo sysctl -p and then

cat /proc/sys/net/ipv6/conf/all/disable_ipv6

Still no success.


I fixed the “host unreachable” problem. The config file had a bad gateway address.

No I have run

sudo apt update


but there is still no sign of xrdp or tiger vnc.


Somehow tiger vnc showed up, and it’s now installed and running a virtual desktop.

hii @Rtc

when i add this key in XML file it shows

“Error on line 158 char 17:odd character ‘&’, expected an quote mark after equals sign when giving valve for attribute ‘name’ of element ‘key’. this entire file has ignored”

please help

On my installation, ‘’‘nmcli connection show’‘’ keys for my Ethernet and WiFi connections list. However, /org/gnome/settings-daemon/plugins/sharing/ has no /vino-server/enabled directory. Is there a way to use the Gui to add the Name UUID data?

the quoted lines contains exotic quotes around enabled and b. change for “'”

1 Like

I managed to get vino working, what a joke. Vino is unusably slow and pointless.
Can anyone give specific instructions for getting a usable RDP working on the NVidia tx2? It would be nice if it worked with the windows rdp client as thats reliable, proven and works great.

For those people who can stand the sluggish (but usable) built-in Shared Desktop approach, full working instructions to move to a headless remote display setup are here:

Works well enough for me so that I don’t have to sit in a room on my own listening to my Nano case’s fan when it’s working hard, or have to cart around the Nano, keyboard, mouse, monitor and cables to use it elsewhere.

I switched to NoMachine nxserver instead of vino and am much happier now with the speed.

@Rtc: Thank you so much. This helped me resolving the remote-sharing crash.

Ubuntu 18.04 on Jetson Tx2

This helped me. This is the page in dusty-nv’s GitHub: https://gist.github.com/dusty-nv/0329cd330edb608673a7c016be901be8

Can this be done on a pure headless setup? I did the initial setup in headless mode so I cannot access the “Desktop Sharing” app from command line