Ubuntu18.04 This system has been minimized by removing packages and content that are not required on a system that users do not log into

I installed the Ubuntu 18.04 system on NVIDIA Jetson AGX Xavier.Everything went well until I tried to install the cartographer algorithm on this machine.After installing Ceres solver and Abseil, I restarted the machine and it was like this.

Ubuntu 18.04.6 LTS xavier -desktop tty1

xawier desktop login: xavier

Last login: Thu Mar 2 21:01:17 CST 2023 on tty1
Helcome to Ulountu 18.04.6 LTS (GNVLinux 4.9.140-tegra aarch64)
. Documentation: https:ihelp.ubuntu.com
s Management :https:illandscape.canonical.com
& Sunport: https:iubuntu.coadvantage

This system has been minimized by re oving packages and content that arenot required an a systeam that users do not log into.
TO restore this content, you can run the "unminimize’ comnand.
Expanded Security Maintenance far Applications is not enabled.
0 updates can be applied irnediately.

Enable ESH Apps to receive additional future security updates.
See httos:/ubuntu.coves or run: sudo pro status
Failed to connect to https:// changelogs.ubuntu.coveta-release lts. Check your Internet connection or proxy settings
/home/xavier/.zshrc:source:103: no such file or directory: /mnt/sda/catkin_ws/devel/setup.zsh

Error occurred when I ran the sudo unminimize command

Err:6 http:/ /mirrors.tuna.tsinghua.edu.cn/debian bullseye InRelease
Could not resolve ’ mirrors.tuna.tsinghua.edu.c n’
Err:7 http:/ /mirrors.tuna.tsinghua.edu.cn/debian bullseye-updates InRelease
Could not resolve ‘mirrors.tuna.tsinghua.edu.c n’
Err:8 http:/ /mirrors.tuna.tsinghua.edu.cn/debian bullseye-backports InRelease
Could not resolve ‘mirrors.tuna.tsinghua.edu.c n’
Err:9 http:/ /mirrors.tuna.tsinghua.edu.cn/debian-security bullseye-security InRelease
Could not resolve ‘mirrors.tuna.tsinghua.edu.c n’
Err: Timeout was reached
W: Failed to fetch http:/ /mirrors.tuna.tsinghua.edu.cn/debian/dists/bullseye/InRelease Could not resolve ‘mirrors.tuna.tsinghua.edu.c n’
W: Failed to fetch http:/ /mirrors.tuna.tsinghua.edu.cn/debian/dists/bullseye-updates/InRelease Could not resolve ‘mirrors.tuna.tsinghua.edu.c n’
W: Failed to fetch http:/ /mirrors.tuna.tsinghua.edu.cn/debian/dists/bullseye-backports/InRelease Could not resolve ‘mirrors.tuna.tsinghua.edu.c n’
W: Failed to fetch http:/ /mirrors.tuna.tsinghua.edu.cn/debian-security/dists/bullseye-security/InRelease Could not resolve ‘mirrors.tuna.tsinghua.edu.c n’
W: Some index files failed to download. They have been ignored, or old ones used instead.

I suspect that there is no network connection, but when I check the status of the NetworkManager, it has been repeatedly starting and stopping.

I’m very confused, can my Ubuntu system return to normal? How to solve these problems?


I’m not sure what have you done exactly, but simply installing some packages should not have broken the system.

This system has been minimized by removing packages and content that are not required an a system that users do not log into.
To restore this content, you can run the "unminimize’ command.

This is something expected, so there is no need to panic.

Can you elaborate this more, or give any log here?

Thanks for your reply.The problem for the NetworkManager is , it is always in the "start " or “not running” state, as the pictures below.

and it seems unable to install the package ‘polkit’

E: unable to locate package polkit

When I configure my network connection, I cannot start WiFi. That options is always “unavaliable”, though I run

nmcli radio wifi on
nmcli connection up <connection-name> password <password>

The wifi is still cannot be used.(when I run ifconfig -a, it is still “unassociated”)


then if WiFi is not working, are you able to use Ethernet?
Seems more like issues of Ubuntu itself, but not our BSP.
Can you try if re-flash helps? Also, if you don’t insist on using JetPack 4.x/L4T 32.x, I’d suggest upgrade to the latest JetPack 5.1.1/L4T 35.3.1.


Thanks for your reply. I just tried using an Ethernet connection, but it still doesn’t work.😭
I would like to try to upgrade to the latest JetPack 5.1.1/L4T 35.3.1. then , thanks for your suggestion.
btw I don’t quite understand what “if re-flash help” is.😂 Is that an Terminal command?or how can I use it


sorry for making any misunderstanding here…
I’m not saying anything specific, and it just means that flash your board again and see if the issue gets resolved.

I can’t answer, and I don’t know much about ceres. I did see a package note that it is just a least squares solver, which should have nothing to do with login or networking. However, polkit is about permissions and authentication, so whatever messed with that (and I doubt a least squares solver would need to mess with that) would care about polkit.

However, I’m going to suggest that it is rather difficult to reverse those errors without knowing exactly which packages were updated. I am assuming this is the NVIDIA AGX Xavier, and not a third party carrier board variant. A third party carrier board variant would need a modified device tree, and any update which picks the wrong tree could have consequences (although I doubt even that would touch polkit), including (temporarily) failed hardware. So you likely do need to flash again, but you could clone first and have access to a copy of whatever you have worked on.

After cloning (if you choose…this takes a long time and a lot of disk space), you can flash. Then perform just an update:

sudo apt update
sudo apt-get upgrade

Once that is done, then you could create a log file of installing your software again. I don’t think the actual package name is “ceres”, but I’ll use that as an example (it is probably something similar):

sudo -s
apt-get install ceres 2>&1 | tee log_ceres.txt

Then, before you do anything else, copy that log file somewhere outside of the Jetson. It could be to a USB thumb drive, it could be with scp over the network to another computer, but place it where a shutdown and restart to failure won’t be a problem if it fails again. Then we can figure out what went wrong if it happens again, and any form of login could be used to reverse the issues.

Incidentally, before installing ceres again, once the system is updated and where you want it, but prior to installing ceres again, you could once more clone (and part of setting up could be copying data from a previous clone to parts of the new system, e.g., home directory, so the clone could include anything valuable). That way restore to that point is simple (but clones take a lot of disk space).

I almost forgot: If the application uses nvidia-smi to find an NVIDIA GPU, then the application will fail anyway. A desktop PC uses a discrete GPU (dGPU), over PCIe, but a Jetson uses an integrated GPU (iGPU) directly connected to the memory controller. So “finding” the GPU on a Jetson is different than finding a GPU on a PC. Even if ceres normally uses a GPU, it might fall back to CPU.


thanks a lot for your explanation and suggestion, I’ll try to flash my board and see if it can solve the problem.

Thank you for your detailed suggestions. 😍 I will try to flash again and see if it can return to normal.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.