UEFI bootloader change default config with flash

I try to change default configuration (Serial Port Configuration) of NVIDIA Resource Configuration (UEFI bootloader) during the flash (not from NVIDIA Resource Configuration menu). Just to illustrate what I’m trying to achieve I attach image of desired config.

I’m able to build uefi bootloader from GitHub - NVIDIA/edk2-nvidia: NVIDIA EDK2 platform support and flash new bootloader version with sudo ./flash.sh -r -k cpu-bootloader jetson-xavier-nx-devkit-emmc mmcblk0p1.

During the boot I’m able to see that new uefi bootloader is present, so it seems like everything is working correctly.

After that I tried to change default value of config SerialPortConfig (VariableList · NVIDIA/edk2-nvidia Wiki · GitHub). I tried to modify line gNVIDIATokenSpaceGuid.PcdSerialPortConfig|L"SerialPortConfig"|gNVIDIATokenSpaceGuid|0x0|0|BS,NV in file Jetson.dsc.inc (edk2-nvidia/Jetson.dsc.inc at rel-35 · NVIDIA/edk2-nvidia · GitHub), to match my desired config.

Also I tried to add my desired configuration to this device tree overlay:
(edk2-nvidia/L4TConfiguration.dts at rel-35 · NVIDIA/edk2-nvidia · GitHub)

Built was again successful, I copied generated files to Linux_for_Tegra/bootloader (namely: BOOTAA64.efi, L4TConfiguration.dtbo, L4TRootfsInfo.dtbo, uefi_jetson.bin). But after bootloader flash, I can see new bootloader build, but the config is not changed.

Are you able to assist me with modifications to GitHub - NVIDIA/edk2-nvidia: NVIDIA EDK2 platform support (or some other modifications) which I need to make to be able to change Serial Port Configuration to disable, during the flash?

What is the method to check whether the config takes effect or not? Did you also use the UEFI menu to check?

Serial port is causing us some issues during the boot, these issues were still persistent even after bootloader update. So I assume, that the config was not applied. But of course I checked the UEFI menu, configuration was not updated.

It looks like, that I’m able to fix our issue with introducing different device tree for UEFI bootloader (in bootloader-dtb partition) with disabled serial, but I’m not sure that this is the correct approach. Therefore I would prefer to update “UEFI config”.

1 Like

I think that method is the correct one…

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.