Default Disable Serial Port in UEFI

I am trying to do this exact same procedure from this post but the user’s solution is not clear to me. Can anyone explain how this solution was achieved?

I already tried updating the L4TConfiguration.dtbo overlay, but still no luck changing the default SerialPortConfig value.

Hi dhiren1,

Are you using the devkit or custom board for Xavier NX?
What’s your Jetpack version in use?

From the summary of that post, it seems that user use a different dtb for bootloader (UEFI). It could be found in the board config file with TBCDTB_FILE.

I am using the Seeed Studio A203 V2, which is very similar to the devkit.

I actually got to a solution! I originally edited the wrong fields in the L4TConfiguration.dtbo overlay. For those interested in how to customize the UEFI variables using the L4TConfiguration device tree overlay, here is what I did:

  1. On my host machine, I decompiled the L4TConfiguration.dtbo to a .dts file. This file is located in the ~/Linux_for_Tegra/kernel/dtb/ directory.

  2. In the new decompiled L4TConfiguration.dts file, I added the variable SerialPortConfig to the gNVIDIATokenSpaceGuid field

  3. Recompiled the L4TConfiguration.dts file back into a .dtbo

  4. Reflashed my Xavier NX. Done!

I have attached my .dts and .dtbo files for anyone who wants to reference it.
L4TConfiguration.dtbo (909 Bytes)
L4TConfiguration.dts (1.0 KB)

I also used this Wiki page to figure out what UEFI variables I wanted to change.

Be sure to check which space the variable you are setting belongs to. If it is in the public space, the variable will be set in the gNVIDIAPublicVariableGuid field of the dts file. If it is in internal space, it will be set in the gNVIDIATokenSpaceGuid field.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.