R35.1 - Flash Specific Partition: cpu-bootloader. Default variable not change


My goal is to separately flash specific partition: cpu-bootloader to only change UEFI image default setting without doing total flash steps.

My experiment is that:

  1. Change configuration from variable “L4TDefaultBootMode” in “edk2-nvidia” source, and rebuild uefi image successfully.

  2. Put the new uefi binary to BSP folder “bootloader”.

  3. Do flash command “sudo ./flash.sh -k cpu-bootloader ./bootloader/uefi_jetson.bin jetson-xavier-nx-devkit-emmc mmcblk0p1”

After flash steps were done and system boot, I can see the uefi built time was new one, but found the configuration setting for “L4TDefaultBootMode” was not change as I defined. (I checked the string through jumping into UEFI interface after pressing key “ESC”)

But I saw that the default setting will change if I did total flash through “sudo ./flash.sh -r jetson-xavier-nx-devkit-emmc mmcblk0p1”. (All files in BSP packages were not changed, only flash command was different.)

Can you please let me know if I missed any step? Thanks a lot!

That one may need to update the BOOTA64.efi to ESP partition.

Hi Wayne,

Thanks for your hints!
Is it possible to separately flash partition “ESP” from “flash.sh”?
It seems that there is no option “esp” in “flash.sh”. Please feel free to let me know if there is misunderstanding. Thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.