Unable to boot Xavier NX

When I first turn on the Xavier NX everything looks normal with the starting of services but then it blacks out for 1 second then I see this on my screen.

Only thing that I’ve done differently is that I installed mesh central to remotely access the device. Is this screen somehow caused by the installation of mesh central?

SOLVED: Yeah it seems to be an issue with mesh central. I tried to turn on the device remotely and I think that’s what caused it. Once I stopped the mesh central server and rebooted the Jetson device, it started normally.

I am not familiar with mesh. However, if this is a virtual desktop or virtual X server, and if it replaced the standard X server, then it is probably the cause. The actual X server dynamically loads the NVIDIA driver in user space, and to do this, the X server must have the correctly compiled ABI for loading that driver (basically, the binary interface).

The X server itself runs only one application, and normally that is the desktop, e.g., Gnome or KDE. It is the desktop which provides all of the GUI “candy”, e.g., running multiple apps. If the desktop is virtual, then that wouldn’t be a problem, but I’ve only heard of virtual servers. A naive server install would not know that the GPU on a Jetson is integrated directly to the memory controller (an iGPU), but almost every server out there would expect the GPU to be on the PCI bus (a discrete GPU, or dGPU).

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.