Unable to get github invite for GameWorks GitHub organization

I specifically want source code access to the VolumetricLighting repo (https://developer.nvidia.com/volumetriclighting).

Tried applying for GameWorks GitHub organization multiple times but still never receive any response (/gameworks-source-github).

Same issue as this thread here (/applied-for-gameworks-github-organization-multiple-times-and-contacted-nvidia-support-however-i-have-never-received-an-invitation-nor-a-response/236955).

Anyone know if this GameWork Github organization is being managed by anyone at all? I can only post 1 link for the thread, so I shorten the links above.

Hello and welcome to the NVIDIA developer forums @rittikornt.

You do realize that this SDK is legacy? The last commit to the github repo is from 2016.

Regarding the Gameworks Github access this is still managed and for other people the process works. But we also have seen occasional issues like the other thread you referenced and this is being investigated.

One easy pitfall is to misspell your Github username on the EULA page when requesting the access.

Hello, I am aware that it is a legacy SDK from 2016, I would still want to get the source code access to have a look at it, since it seems to take a different approach to VolumetricLighting compared to a popular VolumetricFog implementation (Assassin’s Creed 4, RDR2, TLOU2). The slide doesn’t really give away much of the implementation details, so source code should be more useful.

I think I did correctly spell my Github username though, not sure why I still don’t get the github invite.

Hello, I still couldn’t get the github invite, do you know who I should reach out to?

No worries, I am already looking into this.

As I said, this worked in the past and still does most of the time, but we see the occasional hiccup.

Let me see what I can do to get you access, if not I will try and make the sources available to you as a zip download if that is ok.

If I don’t reply by next Tuesday, please ping me again here. (I have a different time zone from my US colleagues)


Yes, the Zip download works fine for me as well if the github invite takes too much time to process.

Quick update, I didn’t hear back from the necessary people, everyone was busy with GTC.

I hope to get back with more helpful news soon.

Thanks for the update, if you have access to the repo, can you send me the Zip download version?

Hello, is there any update on the request? I would be fine if I can get the download Zip version of the project too.

Sorry, no update yet

And for a download I will also first need to get the ok from the code owners.

I’m on it.

I am not making progress on the Github front, so to expedite I will share a ZIP with you as soon as I have approval for the actual file sharing outside the company.

Regarding github access, did you closely follow the instructions?
Some things that were overlooked by people in the past were:

  • They created a Github account but never approved registration and/or never logged into their account on Github BEFORE applying for Gameworks access
  • They misspelled the github account name in the application form on the NVIDIA page. It is case sensitive AND it does not like “Umlauts” or certain special characters like # or *.
  • For some people it worked after creating a new Github account for this


Thanks for the update, ZIP file would probably work best in this situation it seems.

I followed the instructions, I tried both my github account that’s I’ve been using for 5+ years as well as newly created github account, no luck. I’m pretty sure I didn’t misspell my github account name.

well, this didn’t go anywhere, did it… any updates on the zip file a year later?

Hello @c.stiller and welcome to the NVIDIA developer forums.

Sharing the ZIP of a private github repo is unlikely to happen in a public post.

By now the repo specific to volumetric lighting is deprecated and all relevant NVIDIA projects from previous GameWorks context are in public repositories.

Thanks for your interest!