Physx github source invitation?

i applied for the github source code access by providing my github username as described two days ago
but i didn’t receive any invitation till now although the site says it is just one hour.any info about that?

I got mine in 10 minutes or so.
However, if they are reviewed and approved manually, the person who is doing that may be busy at GTC conference, for example.

They aren’t approved manually, it’s an automatic process. I’m not sure if the problem is on the NV side, or on the Github side, but I have found that Github invitations sometimes seem to disappear even when I send one manually to someone I know.

Same problem here, i tried several times but it does not work. There is another way to access PhysX version 3.3.3?

I also have this problem. I have an account on I’m a registered member of the NVIDIA GameWorks developer program and I have an account on GitHub but when I applied (I tried three times) for the PhysX source code access I didn’t receive any invitation.

I havn’t gotten mine as well its been since 04/2014

Still have the same issue here. 3.3.2 is outdated for VS 2015 so I really need 3.3.3

Same problem here, i tried several times but it does not work. There’s something I can do?

Same problem. Could somebody help?

Same problem here, i tried several times but it does not work. There’s something I can do?

I had this problem too and it was because I entered in my github email address, not my github username when applying for access. Once I filled out the github access request with my github username, it took about 10 minutes to get the invitation.

The problem still exists. I’ve sent a couple of requests, but still didn’t get a single invitation on GitHub.
It’s a real shame that nothing is done about this.

I’m using Bullet in a project at the moment, but I’d like to switch to PhysX after running the PEEL benchmark and deciding it’s probably a better option for my specific needs, however, the invitation is also taking too long for me.
C’mon guys, if the system is so flawed, the least you could do in my opinion is provide a mirror for the Github repository in your own servers, you could still have control on who access it, but at least we’d be able to start using it while the invitation is being processed (if it’s being processed).
I can’t believe I’m being forced to stick with the competition.

Yay! Invitation appeared! Thank you guys! Sorry for the rant.

Still can’t get on there. Been days now.

I guess the problem is on github’s end… I never actually received a proper invitation but when I visited the GameWorks page on github a message “you were invited to join this 3 days ago” appeared, so possibly the notification system on github is broken and the invitation was made in a timely manner but I didn’t get any notification.

The same issue here. I submitted twice: 14.03 and 15.03, today is 18.03 and still no response. For comparison, I received an invitation for Epic’s UE4 right after I entered my github username in the profile.

P.S. I received the invitation on 22.03 i.e. about a week.