Unable to load kernel module for 364.12

I am unable to load a kernel module for 364.12. I know this is a beta driver.
I get this in nvidia-installer.log

The log also mentioned several other unknown symbols.

drm_kms_helper_poll_fini, drm_kms_helper_poll_disable ,drm_kms_helper_poll_init, drm_atomic_helper_disable_plane, drm_atomic_helper_cleanup_planes, drm_helper_hpd_irq_event, drm_atomic_helper_crtc_destroy_state ,drm_atomic_helper_connector_dpms
drm_atomic_helper_check, drm_atomic_helper_connector_destroy_state,drm_atomic_helper_plane_duplicate_state,drm_atomic_helper_plane_reset,drm_atomic_helper_prepare_planes, drm_helper_mode_fill_fb_struct
drm_atomic_helper_set_config, drm_atomic_helper_connector_duplicate_state
drm_atomic_helper_crtc_reset,drm_kms_helper_hotplug_event
drm_atomic_helper_swap_state,drm_atomic_helper_page_flip
drm_atomic_helper_connector_reset,drm_atomic_helper_crtc_duplicate_state
drm_atomic_helper_update_plane

I am on linux kernel 4.2.

The problem still persists with 364.16. I must be missing a kernel module.

nvidia-bug-report.log.gz (134 KB)
config.gz (27.7 KB)

Confirm. kernel 4.4.0 Ubuntu 16.04, 364.16:
ERROR: Unable to load the ‘nvidia-drm’ kernel module in nvidia-installer.log

please attach nvidia bug report

If you look at my second post you’ll see that I have. Nothing is in the bug report since
it is generated from a working 352 series. I’ll resend my kernel config. That’ll be more
useful.

config.txt (123 KB)

I figured out on my own what the problem was. I needed drm_kms_helper.ko built. However, nothing
selects DRM_KMS_HELPER unless you selects some per card drm module that needs it. Building drm.ko by selecting DRM won’t give me the kms helper symbols I need. I and maybe ‘dbelyakin’ are building our own kernels without unneeded drm modules.

To fix this either build a module that selects DRM_KMS_HELPER. I suggest radeon but don’t build nouveau.
Another fix is to alter drivers/gpu/drm/Kconfig. Add the line ‘select DRM_KMS_HELPER’ to the ‘menuconfig DRM’ entry. Place it right under line 14, under DMA_SHARED_BUFFER.

After that the problem went away.

We had the exact same problem here with out GTX 1070 and Ubuntu 16.04
The solution was: disable “secure boot” option in BIOS

Thanks MaEtUgR.

I have encountered some problem when installing GTX 1080 with Ubuntu 16.04.
Disable secure boot in BIOS works for me.

Also the procedure I have followed is the link below, hope this might be helpful to some other people.
http://www.allaboutlinux.eu/remove-nouveau-and-install-nvidia-driver-in-ubuntu-15-04/

Hey,

Thanks for the thread.

I’m on Fedora 25 and am doing a fresh install dual boot w10 F25 and went to install the latest NVidia drivers and got the error of :

Last few lines out of install.log

-> Driver file installation is complete.
-> Installing DKMS kernel module:
-> done.
ERROR: Unable to load the ‘nvidia-drm’ kernel module.

Got the VGA compatible controller: NVIDIA Corporation GM206 [GeForce GTX 960] (rev a1)
Was installing 375.26 on 4.8.13-300.fc25.x86_64

This is a new twist in a otherwise previously smooth driver install process.

I am on the Sabetooth FX90 3.0 so looking for Secure boot; I did not see.
Previous installs of NVidia drivers has always been a breeze.

So any advice or links to?