Unable to load the ‘nvidia-drm’ kernel module


I have a V100 GPU on a private datacenter. I am trying to install the nvidia 510 drivers on the computer using this tutorial (option 2) : How to Install/Upgrade NVIDIA 510.xx Drivers on Ubuntu 20.04 LTS - LinuxCapable

However, I get the Unable to load the ‘nvidia-drm’ kernel module error. I tried to see if Secure Boot was enabled, but the command sudo mokutil --sb-state returned EFI variables are not supported on this system.

I have attached the result of nvidia-bug-report.sh
nvidia-bug-report.log (151.1 KB)

You might be running the VM on a vgpu setup so you need the grid driver instead of the normal graphics driver.

[  316.204123] NVRM: The NVIDIA GPU 0000:00:05.0 (PCI ID: 10de:1db6)
               NVRM: installed in this system is not supported by the
               NVRM: NVIDIA 510.54 driver release.
               NVRM: Please see 'Appendix A - Supported NVIDIA GPU Products'
               NVRM: in this release's README, available on the operating system
               NVRM: specific graphics driver download page at www.nvidia.com.
1 Like

I could not find the 510 GRID drivers, so I used the 470. It solved the problem and I managed to install the driver.

However, when I run nvidia-smi, I get No devices were found.

Any idea why?

nvidia-bug-report (1).log (171.3 KB)

[ 10.858310] NVRM: GPU 0000:00:05.0: RmInitAdapter failed! (0x22:0x6a:667)
[ 10.859211] NVRM: GPU 0000:00:05.0: rm_init_adapter failed, device minor number 0

I don’t know if the grid drivers are the correct choice but there seems to be a problem with the underlying host. Without knowing anything about it, it’s impossible to debug.

I contacted my private cloud provider and they need to make an update on their end. This should resolve the issue. Thank you for your help!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.