Unable to receive multicast packets in u-boot Jetson TX2

I have not been able to receive IPv4 multicast packets in u-boot on the patches-v2020.04-l4t-r32.4.3 branch of nvidia u-boot on a JetsonTX2 on a custom carrier board. I have verified this by placing print statements in the net_process_received_packet() function in net/net.c to print the contents of the received packets.

The destination MAC address of the multicast packet I want the Jetson to receive is 01:00:5e:00:00:01 and the destination IP is I can receive other Ethernet packets with broadcast MAC FF:FF:FF:FF:FF:FF but not the multicast packets. I have searched on this forum and elsewhere to see if I was missing a u-boot configuration option but I have not had any luck getting this to work yet. I have looked into the elements of the network stack net.c/eth_uclass.c/dwc_eth_eqos.c to see if I could find where MAC and/or IP filtering is taking place but have not closed in on the solution yet.

Does anyone know the steps required to make the Jetson TX2 able to receive IPv4 multicast packets to MAC 01:00:5e:00:00:01 in u-boot or where in the network stack I should be looking to solve this problem? Does the Jetson u-boot network stack filter on IP along with MAC address or just MAC address? I have run some tests to attempt to determine this but I am not 100% sure yet.

Many thanks,

1 Like

Sorry for the late response, is this still an issue to support? Thanks

I had simplified the description of the problem here (How to enable receiving multicast packets in u-boot) and requested that this thread be deleted. This has not been resolved yet, however. I am looking at how it works in Linux (in particular porting the function of eqos_set_rx_mode in /nvidia/eqos/drv.c) and trying to make u-boot use the same configuration since the multicast MAC address I want is not filtered out in the kernel. I have had no luck finding the eqos documentation. Any support would be greatly appreciated.