Unable to use J41 UART with FTDI and CH340 (USB to TTL) converter

I am trying to connect Arduino UNO in my project through UART. When I am using hardware Serial port(Pin 0 and Pin 1 of arduino UNO) of Arduino UNO, I am only able to receive data sent by Arduino on Jetson NANO. While, when I am sending data to Arduino from Jetson NANO I am unable to do it, there is nothing visible.

On the other hand, when I am using software serial (Using Pin 9 and Pin 10 of Arduino) of Arduino UNO, I am able to send as well as receive data from both ends (Jetson NANO as well as Arduino UNO).

I am also facing the same issue with FTDI cable as well. I don’t have an oscilloscope with me so I can’t check whether NANO is unable to send data or there is some other issue. In addition to this, PL2302 works great in my project.
I am using minicom on NANO to send and recieve data.

hello archit.v,

please note that the bard-rate settings is 115200/8n1 by default,
please also have a try by stopping and disabling the nvgetty service.
for example,

$ systemctl stop nvgetty
$ systemctl disable nvgetty

Hi JerryChang,

I have tried above steps and the problem still persists.
In addition to this, I have also tried to power the external source and logic on both 3v3 and 5V. Both of the configurations are not working.

hello archit.v,

Jetson Nano UART1_TXD (J41 Pin8) only have 1.8V output.
could you please also check Topic 118775, and Topic 78886 for reference.