Uninstalling Tesla Drivers fails

I am trying to uninstall the current Tesla driver from my machines but wehn i run the ./NVIDIA… --uninstall command i get a message saying “There is no NVIDIA driver currently installed”

How can that be possible if i can do a NVIDIA-SMI and it comes back with a normal GPU output. I have also tried to do a yum erase/remove nvidia* and it says that there are no packages matching however when i list the packages there are many NVIDIA packages.

Any help would be greatly appreciated.

There are two different driver uninstall methods, because there are two different driver install methods.

  • runfile install
  • package manager install

If you don’t know how you installed the driver you are trying to remove, it’s very difficult to sort this out.

If you installed via the package manager method, trying to use the runfile method won’t work, and if you do find a script that you can run with ./…, it is not the right script or solution.

If you installed via the runfile method, trying to use a package manager method (yum …) won’t work.


I wasnt the one who installed these drivers but i have tried both ways, yumm and with the --uninstall method and they both fail. What to do next?


Well, a simple solution to describe is to reload the operating system.

Otherwise you’ll need some knowledge in using package managers to figure this out. I wouldn’t be able to give you detailed instructions. The first step would be to list out and understand what packages are currently loaded. It would also be useful to know the driver version.

But if you’re not very familiar with all this, I won’t be able to give you detailed step-by-step instructions. In that case, you could reload the operating system.

Ok i finally got it uninstalled by uninstalling a kmod package. Now when running the installation i am running into this error:

ERROR: Failed to run /usr/sbin/dkms build -m nvidia -v 410.104 -k 4.1.12-61.1.18.el7uek.x86_64: Error! echo
Your kernel headers for kernel 4.1.12-61.1.18.el7uek.x86_64 cannot be found at
/lib/modules/4.1.12-61.1.18.el7uek.x86_64/build or /lib/modules/4.1.12-61.1.18.el7uek.x86_64/source

This is covered in many places. Install the kernel headers or kernel source. If you are doing this in Oracle cloud, oracle should have instructions for how to use their cloud services.

I did install them however the error persists.

Then they are not in the place that the driver installer expects them, or else they are not recognized by the driver installer as valid source for that kernel.

You’ll need to make sure you installed the exact source for the kernel installed/being used. It’s easy to make mistakes here by e.g. yum install kernel-devel (ie. latest) instead of installing for the correct (actual) kernel.