can't uninstall CUDA toolkit after trying all 3 methods

I am confident that I have used run file to install my cuda-10.0. Nontheless, I have tried all 3 methods suggested by
https://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html#handle-uninstallation

  1. the first method suggests that I :
sudo /usr/local/cuda-X.Y/bin/uninstall_cuda_X.Y.pl

but there is no

uninstall_cuda_10.0.pl

or anything with “uninstall” init

  1. the second method:
sudo /usr/bin/nvidia-uninstall

but there is no

nvidia-uninstall

file in the directory.

  1. when I run:
sudo yum list | grep cuda-10

I get:

cuda-10-0.x86_64                          10.0.130-1            cuda

but when I try to uninstall with command:

sudo yum remove cuda-10-0.x86_64

I get error:

No Match for argument: cuda-10-0.x86_64
No Packages marked for removal

So I am not sure how to uninstall my cuda-10.0. The reason I am trying to uninstall is I am missing this file

libcusolver.so.10.0

in my

/usr/local/cuda-10.0/lib64

directory. if there is a way of restoring the file without having to reinstall cuda or how to uninstall cuda-10.0 properly, please let me know.

Thanks

1 Like

The output of the tools you have used suggest to me that you did not use a runfile install method but actually used a package manager install method. I don’t wish to argue about it.

The command you have used for uninstall is not contained anywhere in the linux install guide. The given in the uninstall section:

https://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html#handle-uninstallation

is intended to refer to the same that was used for install. It is almost certainly not:

cuda-10-0.x86_64

because there are no instructions for CUDA install anywhere that I am aware of, that refer to such a package name.

The install package used was almost certainly “cuda”:

cuda-10-0.x86_64                          10.0.130-1            cuda
                                                                ^^^^

I suggest following the linux install guide.

If you have a missing component (not sure how that came about) you should be able to simply re-install the same CUDA version (10.0). To get the package manager method to cooperate, it may be simplest to uninstall. However with a bit of googling I believe you should be able to discover commands to make the package manager for your linux distro do a force reinstall. This capability is not specific to CUDA. However the runfile installer should not require any removal/uninstall. In both cases with a bit of reading of the documents, you should be able to make the reinstall process easier by skipping the driver install (very straightforward with runfile installer, with package manager would involve a force reinstall of cuda-10-0 rather than cuda).

1 Like

Thanks.

I just reinstalled without uninstalling anything and it seemed to have worked fine. The missing “libcusolver.so.10.0” file is restored.