Failed upgrade from CUDA Toolkit 7 to 8

I have a Dell T7910 workstation with two K6000 GPUs running RHEL 7.0

I previously installed Cuda Toolkit 7. It worked fine. I wanted to install Cuda Toolkit 8.

I tried to uninstall CUDA Toolkit 7 but there was no .pl file in the cuda bin directory. So I tried yum remove cuda, as directed in the instructions, but that failed to uninstall.

I then followed the installation procedure for a network package install for Cuda Toolkit 8. I rebooted and now cannot get Xwindows to work. I can get to the command prompt.

Any ideas how I can get the system running properly again?


Follow the instructions in the linux install guide to remove all old installations. Given that there are two different installation methods, and you haven’t identified how you installed CUDA 7, you’ll need to read and understand the guide.

Once you have all old installations removed, then follow the instructions in the install guide to install CUDA 8.

If the package manager method is giving you trouble, you can try the runfile installer method.

Thank you for your reply.

As I indicated in my post, I did try both methods specified in the instruction to remove cuda 7. The:


file was not present. Therefore, I could not use it.

I tried the:

yum remove <package_name>


yum remove cuda

also as specified in the instructions and cuda 7 was not removed.


does not exist thus it cannot be used.

yum remove cuda

fails to remove cuda 8.

Will the runfile installer overcome these issues?

This problem was unsolvable. The system had to be wiped and a clean version of the OS had to be installed.

Nvidia should provide more robust and better tested software to avoid these issues.