Uninstall Cuda from Mac El Capitan

I dont understand why the install feature has been made so simple and the uninstall is nearly impossible for someone who doesnt understand terminal…

I installed CUDA 8 ON MY mid 2014 macbook pro with NVIDIA GeForce GT 750M

I need to uninstall it because as great as it was with some software its also clashing with apples final cut pro which has plugins made by devs where CUDA isnt supported forcing me to go back to opencl

For some reason the first version of CUDA i tried to install was 5.0, i dont think i succeeded with that since it was a little more complex then found CUDA 8.

in the develop folder the CUDA 5 folder is there. but in my systems preferences its CUDA 8.9.46 (latest update)

nowhere else can i find another folder on my mac that states CUDA 8

Can someone PLEASE help me uninstall this for my computer. I have deadlines to meet and cant without getting this off the computer.

There is an uninstall section in the installation guide:

http://docs.nvidia.com/cuda/cuda-installation-guide-mac-os-x/index.html#uninstall

Did you follow those instructions?

Are you saying that you don’t have any of these folders on your machine:

/usr/bin/uninstall_cuda_drv.pl
/Developer/NVIDIA/CUDA-8.0/bin/uninstall_cuda_8.0.pl

If you don’t have /Developer/NVIDIA/CUDA-8.0 then I would guess that you don’t have CUDA 8.0 installed on your machine (maybe you already uninstalled it?) Maybe what you’re objecting to is the driver. Did you run /usr/bin/uninstall_cuda_drv.pl ?

http://imgur.com/a/QzdRx

http://imgur.com/a/O12mu

its clearly installed because ive used it in premiere pro and after effects.

if i write that line of code nothing happens.

if i go into developer only nvidia file in there says cuda 5.0

bump

Hi –

Were you able to resolve your problem (i.e. uninstall CUDA)??

On my system, I do not have the file /usr/bin/uninstall_cuda_drv.pl

But I noticed that you have the same GPU Driver Version (310.42.25f01) (http://imgur.com/a/O12mu ) that I do, except mine says: GPU Driver Version: 10.10.14 310.42.25f02

I am trying to upgrade this driver — but can’t seem to figure out how to do it.

FWIW – my problem is slightly different (see below) - but I also needed to uninstall and install CUDA

My problem: https://devtalk.nvidia.com/default/topic/990015/cuda-setup-and-installation/help-cuda-7-5-or-8-devicequery-failing-not-working-on-macbookpro-2013-os-x-10-11-gt750m/

Also here: https://devtalk.nvidia.com/default/topic/990092/cuda-setup-and-installation/how-to-upgrade-nvidia-display-driver-310-42-25f02-geforce-gt-750m-macbookpro-late-2013-/

I also cannot uninstall CUDA and need to do so. Could you please help?

Running 10.11.6 (15G1212), CUDA Driver Version: 8.0.61

I followed the instructions at http://docs.nvidia.com/cuda/cuda-installation-guide-mac-os-x/index.html#uninstall

I succeeded in running “sudo /Developer/NVIDIA/CUDA-8.0.61/bin/uninstall_cuda_8.0.61.pl” which removed the complete “Developer” tree. (Maybe add the info you need to run as su for inexperienced users!)

But there is no

Sirs-iMac:~ sir$ ls /usr/bin/uninstall_cuda_drv.pl
ls: /usr/bin/uninstall_cuda_drv.pl: No such file or directory

Nevertheless, I still have CUDA in my “System Preferences” pane and a lot of CUDA files on my system
e.g.
Sirs-iMac:~ sir$ ls /usr/local/cuda
lib
Sirs-iMac:Library sir$ sudo find . -name “CUDA
Password:
./Extensions/CUDA.kext
./Extensions/CUDA.kext/Contents/MacOS/CUDA

Please help on how to completely remove CUDA.

Thank you

Sirs-iMac:~ sir$ ls /usr/bin/uninstall_cuda_drv.pl
ls: /usr/bin/uninstall_cuda_drv.pl: No such file or directory

bounce

bounce

Does anybody know where one can “officially” get support on this issue? I can’t believe NVidia provides software you cannot uninstall and does nothing about it.

I’m getting errors on each and every login now, this is inacceptable to me.

random internet searcher here. I was having a similar problem. no /usr/bin/uninstall_cuda_drv.pl. Just wanted the CUDA stuff gone. This blender post helped me:

https://www.blender.org/forum/viewtopic.php?t=26750

direct quote from blender.org/u/sunbeamrapier:

Delete the following:

/System/Library/Extensions/CUDA.kext
/Library/Frameworks/CUDA.framework
/Library/LaunchAgents/com.nvidia.CUDASoftwareUpdate.plist
/Library/PreferencePanes/CUDA/Preferences.prefPane
/System/Library/StartupItems/CUDA/

If you installed the tookits and samples, delete the following also:

/Developer/NVIDIA/CUDA-5.0
/usr/local/cuda

end quote

i make no claim that this is a complete uninstall, but now when I log in, it’s nice and clean again. hope this helps.

Thanks for the post. I will try this. Still, I’m very annoyed. That’s really bad practice, nvidia. Will have to find a way around cuda in the future if you have such grave software quality issues.

All you half to do is go to system preferences then go all the way to the botom where the icon is located an then right click on the icon the click on remove “whatever the soft ware name” preference panel teh go to yore trash then empty it and it is gone this is for mac only not for pc

This is not true. That does not remove the software, only the Preference Pane.

sudo su
rm -r /System/Library/Extensions/CUDA.kext
rm -r /Library/Frameworks/CUDA.framework
rm -r /Library/LaunchAgents/com.nvidia.CUDASoftwareUpdate.plist
rm -r /Library/PreferencePanes/CUDA/Preferences.prefPane
rm -r /System/Library/StartupItems/CUDA/
rm -r /Developer/NVIDIA/CUDA-5.0
rm /usr/local/cuda

did the job though. Still, a non-working uninstall that is not being fixed is considered so bad practice by me, that I even consider dropping TensorFlow for its CUDA dependence. I really wonder what’s going on at NVIDIA these days. Maybe too successful.

On 10.11 or 10.12

cd /usr/local/cuda/bin
sudo perl uninstall_cuda_8.0.pl

done

if you did all step and get still CUDA in preferences panel, follow step below:
open terminal and cd: /Library/PreferencePanes/
delete CUDA Preferences.prefPane

Follow the procedure here and got rid of CUDA successfully.

I went to the official Nvidia documentation pointed out by nvidia support and there is still no mentioning of what the user should do in case /usr/bin/uninstall_cuda_drv.pl does not exist. Such crappy software and support.