Unsupported CUDA driver version: 10010

Hello,

I’ve been trying to profile an app that uses the Optical Flow Accelerator on a RTX2080.

I wanted to get some insights of what was happening with Nsight-Systems. However, it seems that I can’t make it work with my current environment. It throws :

Injection 3097EF09 (:1:0:15205) 00:00.019 Unsupported CUDA driver version: 10010.

For information, here is the output of nvidia-smi:
±----------------------------------------------------------------------------+
| NVIDIA-SMI 418.30 Driver Version: 418.30 CUDA Version: 10.1 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 GeForce GTX 680 Off | 00000000:03:00.0 N/A | N/A |
| 37% 33C P8 N/A / N/A | 330MiB / 1998MiB | N/A Default |
±------------------------------±---------------------±---------------------+
| 1 GeForce RTX 208… Off | 00000000:05:00.0 Off | N/A |
| 30% 29C P8 18W / 260W | 11MiB / 10989MiB | 0% Default |
±------------------------------±---------------------±---------------------+

And deviceQuery:
CUDA Device Query (Runtime API) version (CUDART static linking)

Detected 2 CUDA Capable device(s)

Device 0: “GeForce RTX 2080 Ti”
CUDA Driver Version / Runtime Version 10.1 / 10.0
CUDA Capability Major/Minor version number: 7.5

Do you know if should change something, or if I just have to wait until a new version is available ?

Thanks a lot!
Mickaël

Private message sent

I have an nVIDIA GeForce GTX 1060 with Max-Q Design running Ubuntu 18.10.
With driver 418.43 containing CUDA 10.1 driver.
(https://launchpad.net/~mamarley/+archive/ubuntu/staging/+packages)
And cuda_10.1.105_418.39_linux.run is installed.
Nsight Systems 2018.3 installed by CUDA 10.1 is working fine.
But I downloaded the latest version NVIDIA_Nsight_Systems_Linux_2019.1.1.57.run
If I run that one, I get

Warning Injection Dell7577Linux (:1:0:3326) 00:19.963 Unsupported CUDA driver version: 10010.
Warning Injection Dell7577Linux (:1:0:3326) 00:19.963 CUDA injection initialization failed.

So it seems Nsight Systems 2019.1 does not support CUDA driver 10.1 ?

Hello,

You should update Nsight to 2019.2.
Version 2019.2 includes support for CUDA 10.1

https://developer.qa.nvidia.com/gameworksdownload#?dn=nsight-compute-2019-1

Tom’s answer is almost right. To get to the 2019.2 version you want to use:

https://developer.nvidia.com/gameworksdownload#?dn=nsight-systems-2019-2

Thank you!
I found it and am already running it :-)

Thanks for the correction. :-)

Hello,
sorry for hijacking the thread, but I have a very similar problem. I installed cuda 10.1 update 1 which ships with Nsight Systems 2019.3.3 on Ubuntu 18.04.1 with an RTX 2080.
When I enable “Collect CUDA trace” I get “Cuda driver version on device is not supported”. I used the driver version that was shipped with cuda (I believe it was 418.30). Updating it to the very latest 430.40 did not do the trick.

nvidia-smi 
Tue Jul 30 14:05:04 2019       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 430.40       Driver Version: 430.40       CUDA Version: 10.1     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce RTX 2080    Off  | 00000000:01:00.0 Off |                  N/A |
| 36%   44C    P8    19W / 225W |    541MiB /  7982MiB |      6%      Default |
+-------------------------------+----------------------+----------------------+

I tried to find the right driver but I failed to find release notes or any documentation about driver versions required for NsightSystems. Am I missing something?

For profiling, under the covers, Nsight Systems uses the CUDA Tools Profiling Interface (CUPTI), and CUPTI and the driver have to align for the product to work correctly. The CUPTI documentation says that it should always work with future drivers, so I would not have expected this.

Just in case this is a CUPTI mismatch on your system, somehow, my suggestion would be to download the latest Nsight Systems from the webpage instead of using the one from CTK10.1u1. https://developer.nvidia.com/nsight-systems

Thanks. Downloading manually did the trick - nsight-systems works fine now.

Glad to hear it…sorry for the trouble.