Using nvprof with warning of "The path to cupti library might not be set in LD_LIBRARY_PATH"

I want to use nvprof to profile some GPU metrics.

I use the following command.

$ cd /usr/local/cuda-10.2/samples/0_Simple/matrixMul
$ sudo make
$ nvprof sudo ./matrixMul

And it returns

[Matrix Multiply Using CUDA] - Starting...
GPU Device 0: "Xavier" with compute capability 7.2

MatrixA(320,320), MatrixB(640,320)
Computing result using CUDA Kernel...
Performance= 88.04 GFlop/s, Time= 1.489 msec, Size= 131072000 Ops, WorkgroupSize= 1024 threads/block
Checking computed result for correctness: Result = PASS

NOTE: The CUDA Samples are not meant for performancemeasurements. Results may vary when GPU Boost is enabled.
======== Warning: The path to cupti library might not be set in LD_LIBRARY_PATH. By default, it is installed in /usr/local/<cuda-toolkit>/extras/CUPTI/lib64 or /usr/local/<cuda-toolkit>/targets/<arch>/lib.======== Warning: No CUDA application was profiled, exiting

However, I have checked my LD_LIBRARY_PATH with


How can I fix this problem?

Thanks in advance!


The command should look as below:

$ sudo /usr/local/cuda-10.2/bin/nvprof ./matrixMul


Thank YOU! It works.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.