nvprof is not working in Jetson Xavier (Solved)

nvidia@jetson-0423318029348:~/tensorrt_samples$ nvprof bin/sample_mnist
Building and running a GPU inference engine for MNIST
==8419== NVPROF is profiling process 8419, command: bin/sample_mnist
======== Error: incompatible CUDA driver version.

Hi,

Thanks for your feedback. We can also reproduce this issue on our side.
Will check it with our internal team and update information with you later.

Thanks.

Hi,

Please run nvprof as root.

For example:

sudo /usr/local/cuda-10.0/bin/nvprof NVIDIA_CUDA-10.0_Samples/0_Simple/vectorAdd/vectorAdd

Thanks.

@astalll

Thanks!
It works

I get the same error on the xavier, here it is:

$ sudo /usr/local/cuda/bin/nvprof /usr/local/cuda/samples/0_Simple/vectorAdd/vectorAdd

[Vector addition of 50000 elements]
==29965== NVPROF is profiling process 29965, command: /usr/local/cuda/samples/0_Simple/vectorAdd/vectorAdd
======== Error: incompatible CUDA driver version.

Hi, srawrats

Could you use the nvprof tool inside cuda-10.0 folder?
That is, use /usr/local/cuda-10.0/bin/nvprof rather than /usr/local/cuda/bin/nvprof.

Thanks.

/usr/local/cuda is symbolically linked to /usr/local/cuda-10.0

YES, it is symbolically linked.

Could you help to give it a try?
It may work since this is an authority issue.

Thanks.

FYI–

Another method to address this is to "sudo chmod a+s which nvprof"… then you won’t need to “sudo” everytime you want to execute it.

–tim