Very high latency on CSI cameras on Jetson Nano

Hi there!
I have an issue with Jetson Nano. I have terrific lags on my Jetson Nano, even with downscaled video to 640x360 I am not able to get closer to real-time work of a camera.
I run my camera in Python3 with OpenCV in the way many tutorials show.
What should I check? What may be causing horrible latency?

Thanks in advance.

hello lukas.ungier,

please share the details of your sensor capability,
for example,

$ v4l2-ctl -d /dev/video0 --list-formats-ext

you may also helps to narrow down the issue,
you may refer to Applications Using V4L2 IOCTL Directly to enable V4L2 IOCTL to verify basic camera functionality.
for example,
please given stream-count to test camera streaming, it’ll also report frame-rates.

$ v4l2-ctl --set-fmt-video=width=1920,height=1080,pixelformat=RG10 --stream-mmap --stream-count=300 

I have two identical cameras and for both of them the output is the same as down here:

ioctl: VIDIOC_ENUM_FMT
	Index       : 0
	Type        : Video Capture
	Pixel Format: 'RG10'
	Name        : 10-bit Bayer RGRG/GBGB
		Size: Discrete 4032x3040
			Interval: Discrete 0.033s (30.000 fps)
		Size: Discrete 1920x1080
			Interval: Discrete 0.017s (60.000 fps)

What should I get after calling that second command?

hello lukas.ungier,

you may install v4l-utils if you did not have v4l2 standard control tools.
i.e. $ sudo apt-get install v4l-utils

there’s V4L2 IOCTL to verify basic camera functionality.
you may enable the stream as following,
$ v4l2-ctl --set-fmt-video=width=1920,height=1080,pixelformat=RG10 --stream-mmap --stream-count=300