VIC Configuration failed image scale factor exceeds 16

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU) Jetson
• DeepStream Version 6.0
• JetPack Version (valid for Jetson only) 4.6.1
• TensorRT Version
**• How to reproduce the issue ?
The system connect to RTSP after working a while is stop and appear error message as in the below image

The system have 3 models:
1- primary - batch size 1
2- secondary 1 detection - batch size 16
3- secondary 2 classification - batch size 16

Could you try to set the scaling-compute-hw = 1 in your nvinfer config file? It may be that the input resolution of the models and video resolution differ too much.

Still the error appear. One more information I used MODE 15w.

What do you meam “MODE 15w”?
We can’t judge which plugin of yours went wrong based on the log you posted. Could you show your whole pipeline and attach a full log with GST_DEBUG=3?
Or you can set the GPU mode to all the plugins, like pgie, sgie, nvvideoconvert…

Attached the log file
log.txt (18.4 KB)

Attached the meaning of MODE 15w
Screenshot from 2023-03-30 10-54-59

What’s your whole pipeline like and could you update the deepstream to the latest version?
If not, could you attach your whole app to us?

I cannot attached my pipeline but will explain it also I cannot update deepstream version.

The pipeline connect to camera via RTSP. The first model (primary model) input the the whole frame then after detection the object. The detected object will access the second model (secondary 1) after will access the classifier (secondary 2).

Attached model configuration file.
primary.txt (809 Bytes)
secondary1.txt (845 Bytes)
secondary2.txt (790 Bytes)

We don’t know from which nvinfer reported the error just from the log you attached. So you need to add scaling-compute-hw=1 to each of the config file. But I see that you only added parameters to one of them.

After I add scaling-compute-hw=1 to all my mode configuration still error appear.

There is no update from you for a period, assuming this is not an issue anymore. Hence we are closing this topic. If need further support, please open a new one. Thanks

Now, it’s not the VIC error. You can refer to the link below to change some open source code to fix the new problem or you can update the DeepStream to 6.2 and set the crop-objects-to-roi-boundary=1 para.

Is DeepStream version 6.2 fix this issue??

Yes, you need to set the parameter in the nvinfer config file: crop-objects-to-roi-boundary=1

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.