Visual noise on Fedora 22 on 750m

So I’ve been having this problem with my 750m on my Fedora partition where there’s this visual noise occurring on the screen. Its almost as if the pixels are moving, kinda hard to describe. Anyway this problem only manifests itself on the Linux nVidia proprietary drivers. Windows works just fine and the open source Linux drivers don’t have this problem either. Hopefully someone can assist me with this.
nvidia-bug-report.log.gz (60.1 KB)

I’ve managed to get a video of the problem, its more clear in the beginning of the video.

http://a.pomf.se/quszsw.mp4 is blocked by IT. Any other url?

Here’s youtube link instead https://youtu.be/jDVaFdmpTRo

Gonna bump this, really would like some help since this has been plaguing me for months.

Does the problem change or go away if you open nvidia-settings and play with the dithering controls in the display device page?

Wow yes I had to fiddle around and change the dithering settings in order to fix it (changed dithering from temporal to dynamic). I could’ve sword I had tried that before and gotten nothing. I appreciate the help a bunch, thanks!

Thanks for confirming, raschy. I grabbed the EDID of your monitor out of the bug report log and I’ll try to see if it’s possible to add it to a blacklist somewhere to disable temporal dithering by default.

Just to confirm, which dithering settings looked the best for you?

The best settings for me were Static 2x2 dithering with a depth of 6pc, although Dynamic 2x2 was nearly as good.

Hello!

I would like to confirm that I also noticed the dithering&noise issue. Although I managed to track it down within minutes (as described here), the problem returns after a reboot, and simply opening and closing nvidia-settings will fix the issue. However, in my case I discovered that Dynamic 2x2 gives cleaner results than Static 2x2.

This is an ASUS G752VT laptop (G-SYNC monitor, with an NVIDA GTX970M GPU). Kernel version is 4.4.1-2-ARCH, and it’s using the latest nvidia drivers (nvidia 361.28-1 package, as of writing this). I have also tried using nvidia-dkms, but the results were the same. I could upload the EDID file a link, if necessary.

Hi omninonsense, Please attach nvidia bug report. Did you connected external display to laptop? Is this issue on laptop panel or external display? What desktop env you are running KDE, GNOME? Is it possible you share video showing this issue?