Color banding and animation issues with 520.56.06

After switching from the 515.49.19 vulkan beta to 520.56.06, I started seeing some odd color banding any time a blur effect was applied. It almost looks like it’s 8-bit color instead of 24-bit, but only on certain parts of the screen. It also happened on the SDDM login screen but only when the blur effect was applied. When there was no blur it looked fine. The interesting thing is that I have four monitors, and I was only seeing this happen on two of them.

Also the new driver seemed to break certain window animations. For example, the burn-my-windows animations would continue showing the full window while the animation was running, and then when the animation finished the window would disappear.

All these issues went away when I reverted back to the 515 series vulkan beta.

I am on Arch with kernel 6.02, plasma 5.26.1, and RTX 3080 Ti. Another user in the Arch forum has reported the same issue.

2 Likes

I also experience this issue. I have two same 240hz screens, both connected via DP. It only happens on one of them. It appears to get progressively worse the higher refresh rate I set.
I have a 3080 with the 520 drivers.
This doesn’t happen with nouveau.
I’m gonna try to downgrade later today and will report whether it helps.

I can confirm that downgrading to 515.76-1 works.

This turned out to be the final straw for me. I saw an AMD 6950xt on sale this morning for $800 and pulled the trigger, will be selling my 3080 Ti to break even. I got tired of all the issues with the nvidia driver… this bug, being stuck at the highest power level for a whole year until a fix came out, poor VR support, wayland still not working properly, high gpu usage on idle desktop, etc. So best of luck, but I will not be available to test any fixes for this issue.

1 Like

Can someone affected by this problem please try opening nvidia-settings, navigating to the page for the affected display device, opening the “Controls” tab and checking the dithering settings? Please also try changing the “depth” setting from Auto to 8bpc and/or changing the Mode setting.

1 Like

I am back on the 515 series driver, but I will say that I have the Dithering control set to Disabled on all monitors, which also disables the Mode and Depth settings. It doesn’t look like the entire screen is using a low color mode, just certain areas like transparent konsole windows with the blur effect enabled, sometimes the shadows under windows, and window title bar gradients. The rest of the screen looks like full color. Sometimes these areas render correctly for a few seconds first and then switch to the low color look. In SDDM, it looks fine until the blur effect kicks in and then looks like low color mode while blurred. So I don’t think it’s a signalling issue, seems more like it has something to do with blur or transparency effects rendering incorrectly.

1 Like

Good for you. I also plan getting a new AMD GPU ASAP. Still gonna have to live a few months with my Nvidia

EDIT: perfect, now I cannot answer to aplattner, cause I have reached the reply limit. Here’s the answer:

Gonna upgrade back to 520 today and will try. But iirc I’ve tried it with no success.

Changing the settings doesn’t do much. Even worse on darker colors. My driver version with problem is
520.56.06

Images with the problem Dropbox - Zrzut ekranu z 2022-10-20 17-09-24.png - Simplify your life

2 Likes

The picture from my camera to show what is wrong Dropbox - IMG_20221020_172822.jpg - Simplify your life

1 Like

I also have this color banding issue with the newest nvidia driver on my Dell Monitor connected via Display Port.
Im using Manjaro LTS Kernel 5.15.

Here is my Topic from Manjaro Forum, that i created 5 days ago… with additional informations about my system and so on:

https://forum.manjaro.org/t/nvidia-dithering-mode-no-longer-working-after-the-nvidia-5-20-driver-update-from-today-release/124494

1 Like

I also changed the differend dither modes, but no success.
https://forum.manjaro.org/uploads/default/original/3X/9/3/937268fb73fe05b48a508454b6b9b1fd488c015d.jpeg

Im not played with the depth setting yet… i rolled my system back to the old Kernel and hope nvidia will fix this horrible bug soon :(

Same issue here, I’ll wait for a fix :)

Manjaro Linux
KDE Plasma 5.25.5
Kernel 6.0.2-2 (same issue with 5.19.16-2)
X11
RTX 2080 with 520.56.06 driver
G-SYNC compatible 240 Hz monitor using DP (no issue with another 60 Hz monitor without G-SYNC using HDMI)

I change depth from 8 to 6bpc and it solved the problem for me!

I have the same problem :(. Please, fix it is horrible.

Latest driver 525.60.11 with kernel 6.0.11-1 didn’t change anything :(
Playing with depth (auto / 6 / 8) didn’t solved this issue for me.

@aplattner if you need more information like logs or anything else please tell us!