Visual Studio configuration file '(null)' on VS 2005 when compile examples

Error on compile examples
I get

nvcc fatal : Visual Studio configuration file ‘(null)’ could not be found for installation at ‘C:/Program Files (x86)/Microsoft Visual Studio 8/VC/bin’

what is this ? :">

and what can i do ?

:ph34r: :ph34r: :ph34r:

I also get this error, anyone have any ideas? I am running Windows XP 64-bit.

Don’t know if this has anything to do with it, but I previously installed VS 2008, and uninstalled it and installed Visual C++ 2005 Express Edition to work with CUDA.

yes i did …

i download the 32 bit… and install that

this will work for you …

Has any one try with Visual C++ 2005 version 8.0.50727.42. I have this error. I also try to install Visual C++ 2005 Express Edition, but is does not work too.

I run WindowXP 64 on AMD64 machine.

Thank a lot.

I seem to remember going through this that visual studio on xp64 does not install the 64bit compiler by default. Go back to the visual studio installer and check in custom installation and turn on all the options to get installed. Then studio solutions/projects can be built for 64bit (including CUDA ones).

Here’s a little more detail: go into windows control panel add/remove programs and select visual studio. Click Add or Remove features. Under Language Tools->Visual C++ select: X64 Compilers and Tools

Now when you’re building project, build for x64 not win32

Does this help?

Thank you. I ''ll give a try and report results

Hey, is there a definitive answer for this? I’m getting this error on Windows XP 64. I’m trying to create a 32-bit .dll.

I had the same problem: Running WXP 64, VS 2005 Express, NVIDIA toolkit and SDK for WXP 64.

Following can.not.lose’s suggestion, installing NVIDIA toolkit and SDK for WXP (not the 64), resolved the issue.

With some additional hacking able to compile all the SDK sample code (except for the OpenMP dependent one.)

It worked, thanks a lot!

I’ve installed CUDA 2.2 on a x64 XP without a GPU card (for emulation only). The SDK examples didn’t compile and printed "Visual Studio configuration file ‘(null)’ … " to the output (error). I’ve installed X64 Compilers ant Tools as described above, then changed project properties -> Configuration Properties -> Linker -> Advanced -> MachineX64 (For EmuDebug Configuration). Then changed the platform in the configuration manager to x64.

It works now! :thumbup:

Hello,

I’m trying to compile the Szeta.cu example in a x64 machine using Matlab r2009a. To change project properties, you had to have a Visual C++ project. Have you created one ? What files have you include in your project ?

Thanks

My solution is here : http://forums.nvidia.com/index.php?showtopic=98319. I don’t had the ‘vcvarsamd64.bat’ option file. This works if you are using nvcc from Matlab (in order to create CUDA Mex-Files).

Hi,

I had the same problem in Visual Studio and it helped just to use --machine 32 option in compilation command with nvcc