Problems with Visual Studio on 64-bit Vista (answered) Missing config file or files skipped on compi

I’ve got Vista Business 64-bit and Visual Studio 2008. I was having troubles compiling the sample programs, and it took me a while to find the answers.

I downloaded the 64-bit files from the site and the sample programs all ran fine. However, when I tried to compile the Solutions in VS it gave the error about not being able to find the config file: ‘null’

After some forum reading I realized, well duh, I need to compile for 64-bit. There is a drop-down menu in VS that said Win32, I changed it to x64. Then the compiler just skipped all the files.

Finally, I found out that the default install of Visual Studio 2008 (or 2005 I think) does not include the 64-bit compiler for C. I went into the “Control Panel > Programs and Features” and changed my install of VS to include “Language Tools > Visual C++ > X64 Compilers and Tools.”

Now it works great. I hope if you’re having these problems this post helped.

So, in compiling programs, make sure you are using the same mode (32-bit or 64-bit) for the SDK, for Visual Studio, and for your system.