Want to flash target JETSON_NANO_DEVKIT via sdkmanger but jetson nano 2GB devkit and jenson nano are always included, thus always fail

I tried to flash my Jetson nano devkit B01 using sdkmanager ( ) cli runing in docker. The response file contains the following arguments:

product = Jetson
version = 4.5.1
targetos = Linux
host = false
target = JETSON_NANO_DEVKIT  (tried with P3448-0000, still no luck)
flash = all
additionalsdk[] = DeepStream
select[] = Jetson OS
select[] = Jetson SDK Components
offline = true
license = accept
datacollection = enable

recovery = manual

postFlash = install
ip =
user = nvidia
password = nvidia
retries = 2

When specifying the target JETSON_NANO_DEVKIT, I suspect JETSON_NANO and JETSON_NANO_2GB_DEVKIT must be excluded. However the sdkmanager always included them the flash operation list, no way to deselect them.

Because of that, the whole process failed

      - Drivers for Jetson: Up-to-date
      - File System and OS: Up-to-date
      - Device Mode Host Setup in Flash: Installed
      - Flash Jetson Nano (Devkit): Installed
      - Flash Jetson Nano 2GB (Devkit): Failed
      - Flash Jetson Nano: Failed
      - Device Mode Host Setup in Target SDK: Failed
      - DateTime Target Setup: Failed
      - CUDA Toolkit for L4T: Failed
      - cuDNN on Target: Failed
      - TensorRT on Target: Failed
      - OpenCV on Target: Failed
      - VisionWorks on Target: Failed
      - VPI on Target: Failed
      - NVIDIA Container Runtime with Docker integration (Beta): Failed
      - Multimedia API: Failed
      - NVIDIA Nsight Systems: Failed

  ===== Installation failed - Total 17 components =====
  ===== 2 succeeded, 13 failed, 2 up-to-date, 0 skipped =====

How could I tell the sdkmanager not to flash “Jetson Nano 2GB (Devkit)” and “Jetson Nano”

Hi hotribao,

I tried with the above response file but couldn’t repro the issue.
The command line I was using is

sdkmanager --cli install --responsefile <absolute_path_to_response_file>

Can you please paste the exact command line used in testing?

hi @EdwardZhou ,

I am using sdkmanager on docker, thus the command line that I typed is following:

docker run -it --rm \
	--privileged -v /dev/bus/usb:/dev/bus/usb/ \
	--network host \
	--name nvidia-skdmanager \
	-v /usr/nvidia-sdk-home:/home/nvidia \
	sdkmanager: \
	    --cli install --responsefile /home/nvidia/jetson-nano-response.ini

I have just tried that again. Please find attached the screenshot, as you can see there, items “Jetson Nano 2GB (Devkit)” and “Jetson Nano” are listed and no way to unselect them.

I also attach the response file and the log file. I didn’t let the flashing process run this time because I have my devkit fully installed with SDK and it will take me a lot of time to flash it again.

A side note, when this issue happens, the “Jetson Nano (Devkit)” was flashed successfully. It is just that instead of going straight to the Jetpack installation step, it quited. And I had to launch the “–cli install” again with “–flash skip” in order to install Jetpack.



jetson-nano-response.ini (4.8 KB)

sdkm-2021-05-10-04-30-15.log (21.7 KB)

Hi hotribao,

Can you please also attach the sdkml3*json file in the ~/Downloads/nvidia/sdkm_downloads/ directory?
I noticed that the response.ini file contains one line:
offline = true
This will make SDK Manager to load json file from the ~/Downloads/nvidia/sdkm_downloads/ directory, instead of downloading the json file from Devzone server. I’m not sure whether the local json file is update to date or not. So need compare it with the one on Devzone server.

As an alternative, can you change this line to offline = false in the response.ini file and retry?

hi @EdwardZhou ,

please find attached 2 sdkml3*.json in the sdkm_downloads folder. I noticed that there are files with same name in folder .nvsdkm/dist with the exactly same content.

And yes, trying with offline = true show the expected option screen, i.e. only one item “Jetson Nano (Devkit)”. Before performing the --cli install, I did make an --cli downloadonly because I going to install/flash more than one devices and I hope the offline = true helps save time.

Thank you.
from-downloads-sdkml3_jetpack_l4t_451_deepstream.json (9.3 KB) from-downloads-sdkml3_jetpack_l4t_451.json (229.2 KB)