What means "Nvidia kernel module missing, falling back to nouveau"?

I trying to use Linux (Fedora 36), but I’ve have many problems… the most important is my screen is constantly flickering. I have a NVIDIA Quadro P1000 4GB (4xMini DP) Tiny and also install the RPM Fusion free and non free repositories.

Fedora run smooth initialy but before showme the Gnome desktop, it show me this message"NVIDIA kernel module missing, falling back to nouveau" .How can I solve this problem? Is there any solutión?

I really want to use linux, hope you can helpme!

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

Here is @generix
nvidia-bug-report.log.gz (60.0 KB)

Please disable secure boot in bios menu.

Great… I disable secure boot in bios… but my screen still flickering altought not as often.
In this point… are there any other solutions that can I tried? @generix

Please create a new nvidia-bug-report.log with secure boot disabled.

nvidia-bug-report.log.gz (279.8 KB)

Here is!

The nvidia driver is working fine now. You’re running a Wayland session, if you’re having problems with it, you might try to switch back to a Xorg session to check whether this is a general issue or Wayland dependant.

having the same issue since the latest kernel update from 5.19.16-200 to 6.0.5-200 . going back to 5.19.16-200 kernel version from the grub menu fixed the issue. i have tried with secure boot on and off, sudo dnf remove *nvidia* then reinstalling sudo dnf install akmod-nvidia nothing.

doesn’t seem to be the display server protocol but a issue with the 6.x.x-200 kernel

add an Rpm Fusion repos. And, finally, driver got an update to 520 version and run perfectly fine! the Fedora repo isn’t current, i guess. Enabling the RPM Fusion repositories :: Fedora Docs you can do this or stay on kernel 5.19.16-200

@generix I can’t find the gear icon in the fedora 36 login. Does maybe is part of a setting that I need to power on?
@Hiyadragon thanks… and yep after your comment I change the kernel to the 5.19.16-200 but the flickering is still there. Also remove the nvidia and installed again but… don’t work.

I’m new in Linux, but I don’t want to going back to Windows
I didn’t imagine the hard was to switch to Linux… sigh!

My last bug report
nvidia-bug-report.log.gz (57.6 KB)

Did you already disable Wayland in GDM config as mentioned in the linked article?

enabling rpmfusion will fix your issue and you can use 6.0.5-200