What version of jetpack has the feature "Kernel Boot Sequence " ?only jetpack4.5? how can we make a usb disk image with an easy way?

Is this nvidia developer kit or your own custom carrier board?

More precisely, it takes 10 mins to enter the desktop. Not 10 mins to boot. The boot is finished when you see "vkrobot-desktop login: " on the uart console.

Please remove “quiet” inside your extlinux.conf to enable more log. Currently, the kernel log is not completed.

this is nvidia developer kit

we delete the “quiet” , it become faster to enter the desktop.(4~5 min)
usb disk boot log.txt (124.7 KB)

This is edid read failure. The display driver fails to read the monitor edid through the i2c. These re-tries make your desktop coming out slowly.

[ 5.292784] tegradc tegradc.0: hdmi: edid read failed
[ 5.292823] tegradc tegradc.0: hdmi: using fallback edid

Is this a A02 jetson nano or B01 one? Will you see such issue if you boot from sd?

this is a02

sd card boot log.txt (21.6 KB)

Remove the quiet please… so that I can check the log…

sd card boot log.txt (78.3 KB)
no quiet

sd card enter desktop ,it only take within 1 min

Both sdcard and usb disk has the same display error. Please check if you can use other board to validate this issue.

we change our usb which is higher r/w speed, then it enter the desktop very quickly now

but after we do apt-get update and apt-get upgrade , it no longer boot up .

stu at tegra-i2c : no acknowledge from address 0xxxx

This is jetson nano board issue… not the usb stick issue. That was what I am talking about in previous comment…

we already change the board
both are a02,
is the image not suitable for a02

Can you forget about sdcard image and directly flash your board with sdkmanager first?

the SDKm is so complex, and our network is not so good as foreign contours

Then download the driver package and the rootfs from the website and prepare the BSP by yourself.


Refer to the quick start guide to understand how to use it.

You have to learn how to use this if you want to develop product. The sdcard module is only for evaluation but not for production…

the kit is enough for our students, we want to make some lessons on it,
but the kit is expensive for them , but the usb is a good choice

If you want me to help check your issue, flash the board with above method first.

Is your monitor a pure HDMI monitor? I mean is there any adapter cable on it?

is there some video tutorials, it is difficult to understand the nv document for us

previously, we used a miniHdmi monitor,
now we try a very pure HDMI monitor, but it doesn’t work neither.

It sounds like you have one Nano for several students and you want them to have their own boot drive instead of having their own full dev kit. Perhaps the following will clear up some confusion, although it isn’t an answer…

Is this an SD card model and not eMMC model? Answers to boot questions will change depending on model. Also, if this is not a dev kit (an SD card model plus dev kit carrier board), then other things change.

On the eMMC models there is QSPI memory which changes when you flash the Jetson. Those changes go beyond just creating a boot image. This also includes what are essentially pointers to devices for booting. The implication is that in an eMMC model, even if you boot “most” of it from an external media (e.g., USB thumb drive), there is no possibility of putting all boot content on the external device. The act of flashing such a Jetson changes the Jetson itself, and not just the boot media you see.

The SD card model of a Nano does have all of this content in the SD card (not sure how the SD card model would work if it has no SD card, but other boot media, e.g., just a USB thumb drive, never tried). Basically this means that all content on an SD card for use with an SD card dev kit can be cloned and different people could have different SD cards which are customized, e.g., different login names, different optional software, but eMMC models won’t have this flexibility.
See #50.

Consider that preexisting SD card images might not be the same as flashing once with JetPack/SDKM.

Also, note that it is good you are trying to use a true HDMI monitor, but it won’t do much good if first boot setup isn’t completed. I think you would still see HDMI output though, so no HDMI is some other issue. Anyone with that issue probably needs a full serial console boot log for each hardware change, e.g., when changing monitors and it still doesn’t work, then you’d still want a new boot log to see if the EDID is present (EDID is an i2c query of the monitor by the GPU using the DDC wire of the HDMI…and is mandatory for configuration to succeed, but it doesn’t mean the monitor is within available specs).

You should have a serial UART for serial console logging, and each student should know how to use this. The serial console is both the method of getting a definitive boot log, and also for seeing what goes wrong with video since it functions even when video and networking died. If you have a serial UART cable available for each student, then point them at this URL for how to use serial console:

thank you for your advice.

the jetpack4.5 will flash the QSPI with the boot firmware, so we can boot the image in usb disk.

if for jetpack4.4 we can put the sd card with a normal image in the nano, then change the boot order, to first boot the image in the usb disk.

they both works.

but there will appear some issue some time

You should first deal with the i2c issue first. It has nothing to do with the topic here because you hit such issue even when you use the sdcard image.