Jetson nano Kit B01 Bricked

Nano Developer Kit B01 Bricked

Apparently my USB-SSD has failed and I only see the white Nvidia display every time I power-on. Nothing else. I am not able to find the correct sequence of actions to build a new OS. I have not been able to build form a new flash of micro-SD or USB-thumb-drive of Jetpack 451. I have tried the hardware sequence of power-on, FC-REC-gnd, SYS-RST-gnd, SYS-RST-open, FC-REC-open. Still only the white Nvidia display. I assume QSPI-NOR is preventing a re-build.

What is the proper procedure to rebuild the OS?


Are we speaking of an SD card model, or an eMMC model? SD card model won’t have QSPI issues, everything goes on the SD card. eMMC models do depend on correct flashing of QSPI to match the flashed content.

Normally, assuming you are running an Ubuntu 18.04 host PC without a VM, then putting the Nano in recovery mode allows it to be seen by the flash software. You could normally flash via JetPack/SDK Manager (which installs and runs the flash software). SD card models have some prebuilt images which you can install through simpler tools, e.g., Balena Etcher on Windows, but eMMC models cannot use that.

Which model do you have, SD card or eMMC? If eMMC, then it tends to imply you have a custom carrier board as well, which requires custom firmware.

SD Card. I will format and use Etcher again and let you know the result.

I thought I read that once you change your boot device to USB that the SD card would never be looked for boot again. It would just show up as a common storage device.

No. That did not work. Comes up with an UBUNTU beaver screen with a box:
“The Installer encountered an unrecoverable error. S desktop session will now be run so that you may investigate or try installing again” With an OK box. SI selected OK and there was some line code run then a black screen. I waited for 15 min – nothing. I the power cycle and no message just the white Nvidia display then black screen. I remember reading that this version reformats QSPI into two areas and if you change the boot location to the USB that it will not ever boot from the SD card again. Please check on this new arrangement and advise how I can escape from this LOCK out. thank you.

Please find a native ubuntu 16.04 or 18.04 host and flash sdkmanager to your nano.

This is different from sdcard image which would only update partial boot device. SDKM will update the whole devices.

I do have my older nano that is running 16,04. How do I flash from the old to new nano when the new that has no OS? Do I flash SDKM to USB thumb drive? Or SD?

Sorry, forgot to mention. This ubuntu host need to be a x64 machine. Not a arm64 machine.

When you hear we say term “host”, they are all x64 machine but not arm64 device like nano.

SDKM just flash the nano itself + the sdcard on the nano through the micro usb.

I did get the SDK Manager installed and Login on my UBUNTU 20.04 x86_64 system.
I am at a hold until I get a micro USB cable.

I am sorry to say that we don’t guarantee ubuntu 20.04 would work. That was why my previous comment said ubuntu 16.04 and 18.04…

The sdkmanager can work on ubuntu 20.04, but the software it downloads and tries to install, which we call jetpack, does not support 20.04 yet.

I did not know that the version of UBUNTU running on the PC had any direct relationship to what version would be pushed on to the Nano. I can change the PC to 16.04. I am having a problem finding a micro USB for data. all I find list for charging, none USB 3 data rates. Can you recommend a micro USB for data?

I am not talking about the version pushed to the nano. It is just the tool running on the host cannot work with ubuntu20.04.

all I find list for charging,

I don’t think there is any difference for a micro usb cable… I mean there is no micro usb cable that is only for “charging”… that one could be bad quality cable we should not use.

I find that although none claim to be strictly for charging, that the very cheapest ones are usually of very low quality and have an incredibly tiny number of copper strands. Once you get to the cables which are not the “cheapest” there is about a 33% chance you will get one which works well with large data. Some cables come with devices intended for data, e.g., something which ships with an external hard drive, and those can usually be trusted. Mostly it is a game of chance whether a “charging” cable works well with data.

OK. I’m back with UBUNTU 18.04. I have SDK Manager installed and running.I have a formated SDcard in the Jetson and connect with micro USB. As near as I can tell it is downloading Jetpack 4.5.1. I am seeing slow progress on the Downloading stat. only at 0.80%

When SDK manager is finished, I assume I can disconnect the USB cable, power off the Nano. Then power on the Nano and I should see a good boot with Jetpack installed?

During flash the Jetson has to be connected and in recovery mode. When the unit has flash complete it reboots and install of some options are then added over ssh to a fully booted Jetson, but this requires having completed the first login setup for an account. If the virtual wired ethernet over USB is used for ssh networking, then USB has to remain connected, but it is for networking instead of being for recovery mode. If you’ve instead named an IP address from the ethernet port, then you could technically remove the USB cable at that point (but it wouldn’t be necessary).

So you should see the monitor have activity and offer a first boot setup all by itself. If not, then you could cycle power to get it to reboot, but only do so if the flash (but not ssh optional component install stage) is complete.

FYI, you can (and might prefer due to less complication) uncheck all steps except flash, and complete flash. Or you can uncheck flash if flash completed once, and just check steps to install optional content, e.g., CUDA.

Once actual flash is done and the first boot setup of account is done you can use the Nano almost like a desktop PC.

First try failed. This used PC Ethernet port works OK Windows but not UBUNTU. Tried WIFI but too many time-outs.I was in the basement at the end of WIFI signal. Moved to same room with WIFI router today. Running slow but no errors. I need to study your last comments closely to pick a reboot method. The Nano is connected to the PC and powered now. Downloads for Host and Target are still proceeding. If I let all continue to completion, can I then power off the Nano, attach display, keyboard/mouse and see a first boot/login with power up? I did not make any assignments for any USB or Ethernet ports. I just connected the microUSB on the Nano to a USB port on the PC. Allears as the software identified the Nano , as SDK manager is showing Install pending for CUDA and Downlod in progress for CUDA-X AI for the Targa device.

How do I ensure that the Nano is in Recovery mode? Can this be done now while powered and connected to the PC?

All failed. When all the Downloading and Installs for the Host machine and many all the Downloads for the Target was don I got a screen asking about the flash section. I select Auto and provided the previous username and PW. It could never see the Nano. This was true from the start for the Target box, but when I saw Downloads for the Target I assumed all was OK. Not true. I tried three different cables and 5 different USB ports. No mater what I try I still only see the White screen with the green Nvidia logo. Having nothing better to try I will install UBUNTU 16.04 to see if I can get back the Ethernet port. Any new ideas?

I have installed UBUNTU 16.04 and have restored my Ethernet port. Quickly reinstalled SDK Manager.
No matter what I do I cannot get the software to see my Nano. Any ideas?