When setting higher camara resolutions the Nano Dev kit reboots

Hi all,

I have a nano Jetson Development kit B02 and a connected imx477 camera. After installing the drivers from(Releases · ArduCAM/MIPI_Camera · GitHub) I could interact with the 1080p resolution and I’am able to display a video on the screen.

gst-launch-1.0 nvarguscamerasrc ! 'video/x-raw(memory:NVMM), width=1920, height=1080, format=(string)NV12, framerate=(fraction)30/1' ! nvoverlaysink -e

However when I want to change to a higher resolution for example width=4032, height=3040… The system just reboots and I cannot find any error logs whatsoever.
Runnig: gst-launch-1.0 nvarguscamerasrc ! 'video/x-raw(memory:NVMM), width=4032, height=3040, format=(string)NV12, framerate=(fraction)30/1' ! nvoverlaysink -e

One time I actually got a video feed on the display with a higher resolution but when I wanted a gstreamer pipeline that saves the stream as a file it rebooted and now everytime a higher resolutions setting makes the jetson reboot.

Do you guys have any sugggestions??

One time after rebooting the console stucked and showed the error:

imx477_board setup: error during i2c read  probe (-121)

After a manual reboot the GUI showed: Sorry, Ubuntu 18.04 has experienced an internal…

The followling happends after which it shows the feed for a second after which it reboots;

Setting pipeline to PAUSED ...
Pipeline is live and does not need PREROLL ...
Setting pipeline to PLAYING ...
New clock: GstSystemClock
GST_ARGUS: Creating output stream
CONSUMER: Waiting until producer is connected...
GST_ARGUS: Available Sensor modes :
GST_ARGUS: 4032 x 3040 FR = 29.999999 fps Duration = 33333334 ; Analog Gain range min 1.000000, max 22.250000; Exposure Range min 13000, max 683709000;

GST_ARGUS: 3840 x 2160 FR = 29.999999 fps Duration = 33333334 ; Analog Gain range min 1.000000, max 22.250000; Exposure Range min 13000, max 683709000;

GST_ARGUS: 1920 x 1080 FR = 59.999999 fps Duration = 16666667 ; Analog Gain range min 1.000000, max 22.250000; Exposure Range min 13000, max 683709000;

GST_ARGUS: Running with following settings:
   Camera index = 0 
   Camera mode  = 0 
   Output Stream W = 4032 H = 3040 
   seconds to Run    = 0 
   Frame Rate = 29.999999 
GST_ARGUS: Setup Complete, Starting captures for 0 seconds
GST_ARGUS: Starting repeat capture requests.
CONSUMER: Producer has connected; continuing.

I also can’t find any logs when journalling the nvargus-daemon.service…

When running v4l2-ctl --list-formats-ext

        Index       : 0
        Type        : Video Capture
        Pixel Format: 'RG10'
        Name        : 10-bit Bayer RGRG/GBGB
                Size: Discrete 4032x3040
                        Interval: Discrete 0.033s (30.000 fps)
                Size: Discrete 3840x2160
                        Interval: Discrete 0.033s (30.000 fps)
                Size: Discrete 1920x1080
                        Interval: Discrete 0.017s (60.000 fps)

When running v4l2-ctl --all:

    Driver Info (not using libv4l2):
            Driver name   : tegra-video
            Card type     : vi-output, imx477 8-001a
            Bus info      : platform:54080000.vi:4
            Driver version: 4.9.255
            Capabilities  : 0x84200001
                    Video Capture
                    Extended Pix Format
                    Device Capabilities
            Device Caps   : 0x04200001
                    Video Capture
                    Extended Pix Format
    Priority: 2
    Video input : 0 (Camera 4: ok)
    Format Video Capture:
            Width/Height      : 4032/3040
            Pixel Format      : 'RG10'
            Field             : None
            Bytes per Line    : 8064
            Size Image        : 24514560
            Colorspace        : sRGB
            Transfer Function : Default (maps to sRGB)
            YCbCr/HSV Encoding: Default (maps to ITU-R 601)
            Quantization      : Default (maps to Full Range)
            Flags             : 
    Camera Controls

                     group_hold 0x009a2003 (bool)   : default=0 value=0 flags=execute-on-write
                    sensor_mode 0x009a2008 (int64)  : min=0 max=0 step=0 default=0 value=0 flags=slider
                           gain 0x009a2009 (int64)  : min=0 max=0 step=0 default=0 value=16 flags=slider
                       exposure 0x009a200a (int64)  : min=0 max=0 step=0 default=0 value=13 flags=slider
                     frame_rate 0x009a200b (int64)  : min=0 max=0 step=0 default=0 value=2000000 flags=slider
                    bypass_mode 0x009a2064 (intmenu): min=0 max=1 default=0 value=0
                override_enable 0x009a2065 (intmenu): min=0 max=1 default=0 value=0
                   height_align 0x009a2066 (int)    : min=1 max=16 step=1 default=1 value=1
                     size_align 0x009a2067 (intmenu): min=0 max=2 default=0 value=0
               write_isp_format 0x009a2068 (bool)   : default=0 value=0
       sensor_signal_properties 0x009a2069 (u32)    : min=0 max=0 step=0 default=0 flags=read-only, has-payload
        sensor_image_properties 0x009a206a (u32)    : min=0 max=0 step=0 default=0 flags=read-only, has-payload
      sensor_control_properties 0x009a206b (u32)    : min=0 max=0 step=0 default=0 flags=read-only, has-payload
              sensor_dv_timings 0x009a206c (u32)    : min=0 max=0 step=0 default=0 flags=read-only, has-payload
               low_latency_mode 0x009a206d (bool)   : default=0 value=0
               preferred_stride 0x009a206e (int)    : min=0 max=65535 step=1 default=0 value=0
                   sensor_modes 0x009a2082 (int)    : min=0 max=30 step=1 default=30 value=3 flags=read-only

When I run the nano in headless mode it justs powers off.

When I run the command

dmesg | grep imx

the output is this:

[    1.785636] imx477 7-001a: tegracam sensor driver:imx477_v2.0.6
[    2.086076] imx477 7-001a: imx477_board_setup: error during i2c read probe (-121)
[    2.093628] imx477 7-001a: board setup failed
[    2.098115] imx477: probe of 7-001a failed with error -121
[    2.098692] imx477 8-001a: tegracam sensor driver:imx477_v2.0.6
[    2.554007] vi 54080000.vi: subdev imx477 8-001a bound

Thanks in advance!


hello quintene,

may I know which JetPack release you’re using?
could you please also check Approaches for Validating and Testing the V4L2 Driver for using v4l2 IOCTL to check the basic sensor functionality.

Hi JerryChang!

I’am using JetPack 4.6.3.
The link you mentioned refers to the Multimedia User Guide but I can’t find such entry within the downloads section, do you perhaps have any link/document on how to validate the driver?

Also, I found this FAQ of the arducam Toubleshoot - Arducam Wiki and they mentioned something about the driver not being installed but it’s really unclear what to do to fix this issue.

It’s just really confusing that it worked and still does for a few seconds…

Thanks again!

hello quintene,

that’s link to the developer guide, please double check you’re able to access to it.
recap as below.

  • Use V4L2 IOCTL to verify basic functionality during sensor bringup.
    • For example, to capture from a Bayer sensor with the format 1080p/30/RG10:
      $ v4l2-ctl --set-fmt-video=width=1920,height=1080,pixelformat=RG10 --stream-mmap --stream-count=1 -d /dev/video0 --stream-to=ov5693.raw

you may also check sensor support formats by… $ v4l2-ctl -d /dev/video0 --list-formats-ext.
please assign supported width/height/pixel formats to v4l pipeline for testing.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.