Will CUDA 2.1 support Ubuntu 8.10?

Hi all,

I’m new to the whole CUDA and generic computing on the GPU world. I have Ubuntu 8.10 freshly installed (32-bit), on a machine with GeForce8600GT card.
Ubuntu 8.10 has gcc 4.3.2 as the default compiler version installed, and I understand this compiler version will only be supported in CUDA 2.1 (correct me if I’m wrong please).

So, my question is this: Would CUDA 2.1 support Ubuntu 8.10? I read in the forum it’ll support 8.04. Backporting is an option if that’s the only way I could get CUDA to work
on my machine, but it is not a preferable option. Which leads me to asking also, if there’s any one who managed to get things to work on 8.10, maybe by downgrading gcc?

Thanks,

Liad Weinberger.

No, Ubuntu 8.10 will not be supported in CUDA_2.1.

Is there any estimation as to when it will be supported?

The release after 2.1, so sometime in early 2009.

Cool, thanks. Once 2.1 is out, I’ll backport to 8.04 I guess.

Edit:

I’ve noticed in a previous thread, that Simon Green said:

How founded is this statement? I mean, I’ve tried compiling the SDK on my 8.10 Ubuntu using gcc 4.2.x, and it did pass through a lot of the errors I got when I tried to do so with gcc 4.3.2, however it still reached a linking problem with glut (which I assume I can fix with some effort). So is that really a possibility?

Thanks again,

Liad Weinberger.

Is this a big deal actually? Gentoo is not supported, but CUDA works sweet as hell :)

Well, as I said, I have Ubuntu 8.10 installed currently, and it is known that 2.0 doesn’t react well to gcc 4.3.2. I tried make on the SDK, and got several include errors. Changing compiler version to 4.2.x seems to have worked around these include errors, but I still can’t build the SDK, so I guess it is somewhat of a deal, not sure how big it is at that. This is why I’m trying to figure out if there’s any feasable workaround to simply backporting to 8.04 (when 2.1 is out) or even to the very outdated 7.10.

Or maybe I should just switch to Gentoo huh? :blink:

Is this a rhetorical question? :D

Had the same problem, but I think I’ve got it to work on 8.10, 64 bit version with the help of this thread http://forums.nvidia.com/lofiversion/index.php?t73270.html:

I did something like this, after I’d installed the driver, toolkit and SDK. (Version 2.0)

  1. sudo apt-get install libc6-dev-i386
  2. sudo apt-get install build-essential libglut3-dev gcc-4.1 g+±4.1 -y
  3. sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.1 60 --slave /usr/bin/g++ g++ /usr/bin/g+±4.1

Thanks Fugl, I’ll give that a try.


Edit
:

Awsome! It works perfectly :) Thanks for the tip.