Will pay for help! - Got a strange crash problem with VDPAU

Hello,

  • Been using Linux for a long time and have had a strange problem with VDPAU - that keeps crashing. And would like some expert Linux/Nvidia display guru to solve this.

  • Drivers and everything install perfectly - and i can use VDPAU and watch movies perfectly.

  • But after a few hours of playing movies or doing anything that requires VDPAU: Vdpau crashes after a certain amount of time.

I have noticed the same crash with different Nvidia cards and computers models. Nvidia ION (1 and 2) and Geforce Quadro 600.

And the crash seems to be different depedning on how much RAM or CPU the computer has. The more RAM/CPU the computer has the longer VDPAU can be used.

I can from a Dell computer Optiplex with CPU i7 Intel a Quadro 600 card play vdpau movies for around 5 to 8 hours. Then i need to restart everything (the movie player) then i can resume watching movies for anohter 5 to 8 hours.

Also the same crash is not related to the movie player since i can reproduce this problem with: FlashPlayer (with vdpau), XBMC with vdpau, Mplaye with Vdpau.

Same amount of time in all the different players.

Have tried many different nvidia driver versions but the same result.

Now i am using Puppy Linux Lucid (Based on Ubuntu) http://puppylinux.org/main/Download%20Latest%20Release.htm

What is it in Puppy Linux Lucid that is missing/old/different that makes this strange crash occur?

I see no error anywhere - in the Nvidia Logs.

Is there some memory usage that i should check on Puppy Linux?

I have one clue that might be correct / got it from a highly skilled XBMC developer:

quote:

[i]"it may be some max file-handle limit problem, the main failure reason
in the log file I guess is:

13:58:49 T:2651835200 NOTICE: SpawnThread - fatal error creating thread"[/i]

But not sure if that is correct - been testing to change “File-handle limit” but without any noticable change in when VDPAU crashes.

Need a Linux Guru / Good with display drivers to help me track down this bug."

Anyone up for this?

Would gladly pay for help to solve this,

Best regards,
Johan

try to install the latest x264 ffmepg , xine-lib from source and play the movie with xine player .

Well I guess first verify the process isn’t being killed for going out of ram:

dmesg | grep -i oom
dmesg | grep -i killed

(might give some clues).

Next I would suggest looking at how much memory the player is using when its been playing for a long time. What player ar eyou using btw?

I use vdpau with mplayer with great succeess but I don’t usually play hours of video so… I will say that memory usage of mplayer is usually like half of what it is via vdpau compared with regular software deocding/xv output when playing 4k content.

Hi - I know this is not a trivial bug to reproduce. If you do see it again, please post an nvidia-bug-report.log.gz here, and describe your configuration as thoroughly as possible: video playback application, video details (duration, format, etc.), amount of time to see errors, and so on.

You can consider using the mem= kernel flag to artificially limit the amount of RAM in your system. If the issue is the out-of-memory killer, this will help find a reproduction in a shorter amount of time.

Thanks.