Wine/Crossover, Orion: Prelude, Primal Carnage, other Unreal 3 powered games, black textures.

Sup guys,

I have been discussing this issue with Wine/Crossover devs, so basically what I am going to do is copy and paste some of that discussion, so I don’t have to type all of it again.

I have had “Orion: Prelude” for ages, but I never found the time to actually play it. Now the time has come to rock it. It’s a great game, a real steal for 99 Cents, it’s a lot of fun if you play it with friends and family. Games using the Unreal 3 engine use to run just fine on my AMD HD 7850 GPU. Things have changed though, now that I am testing stuff on my new Nvidia GPU. It would be a huge downgrade, if Nvidia is lacking behind on such an important subject/engine. The game itself performs okay and the graphics are good - for the most part. The only thing that is driving me crazy are the flickering black textures. And to make things worse, this also happens in other Unreal 3 powered games, such as “Primal Carnage.” This bug only affects the ground textures, everything else seems to render just fine. This was tested on vanilla Wine 1.6.2, 1.7.x and on Crossover 14.x. I am willing to gift the Steam version of Orion to a dev around here willing to look at the issue. looking at AaronP I am aware of the fact that Wine is not the same thing as native gaming, but recent Nvidia patch-notes actually mention fixing compatability issues with games running via Wine (such as Far Cry 3). So I guess there is still hope! This is one of the major reasons I support Nvidia btw.

One of the developers of Wine and Crossover has allowed me to use the information he has been able to find out in a very short amount of time. This is the lastest info I got from him on the subject:

Fwiw, this is not related to nvapi.dll. The game works fine on my Nvidia system on Windows with nvapi.dll moved out of the way. The most likely cause is still some floating point corner case in the shader, e.g. a division by zero or other operation that generates INF or NaN. But this is just a guess, no guarantee that this is really what happens.

My system:

  • Ubuntu 14.04.1 64-bit
  • AMD Phenom II X4 945 @default clocks, no OC
  • 8 GB DDR3 Corsair XMS RAM
  • 256GB Samsung Evo SSD
  • MSI Geforce 650 TI OC 2 GB GDDR5 with proprietary drivers enabled; 331.113 (using the -updates repo provided by Ubuntu)

Screenshots:

Orion: Prelude

Primal Carnage

And last but not least, a video from another user experiencing the same issue:
https://www.youtube.com/watch?v=qFLvMTGhnjA

Thank you for your time.

Cheers,
Alex

Update: I have also purchased + tested “Primal Carnage: Extinction” - it shows the same black textures on several maps. Some worse than others.

Sup guys,

I’ll update my own thread: This issue has been fixed in Wine-Staging. I tested all of the affected titles via Wine-Staging 1.7.41 (+ CSMT enabled) and it worked just fine - no more glitchy graphics/textures and great performance!

If you are experiencing this bug, you have two options:

  1. Build Wine-Staging by yourself: http://www.wine-staging.com/

  2. Or, alternatively, use PlayOnLinux to download and install the most recent Wine-Staging build. <- I recommend this due to the fact that it’s an automated process that doesn’t require much user interaction. Perfect for noobs, like myself! Don’t forget to activate CSMT via Wine config though as it substantially improves performance in all of the games mentioned above.

Cheers,
Soniee