Graphic issues with Unreal Engine w/ 343.22

Hello everyone,

I just wanted to report a few bugs that i’ve noticed with the Linux drivers and game ports using Unreal Engine.

This applies to both Borderlands 2 and Painkiller. It also applies to several driver revisions (don’t remember the first version I encountered this). It also seems to be distro insensitive (applies to Linux Mint/Ubuntu and Arch).

The issues stem from enabling certain features in the NVIDIA X Server Settings:

1.) If the Anisotropic Filtering override is enabled (with any value; 1-16), there is a great deal of red artifacts spanning across the entire screen.

2.) If Texture Sharpening is enabled , there is a similar effect on specific textures (or lighting?).

The screenshots are from Borderlands 2 but the same symptoms are present in Painkiller as well. These two titles are the only ones that i’ve experienced this, in Linux.

Just thought i’d let however is interested know. :)

Heyyo,

Wow, that is a pretty messed up bug! :P

Please refer to this guide on how to post issues so NVIDIA can see what exactly is going on for software and hardware to help diagnose the issue:
https://devtalk.nvidia.com/default/topic/522835/linux/if-you-have-a-problem-please-read-this-first/

Thanks for the info. I started a bug submission with NVIDIA support. If there is any update that will help, i’ll post here. :)

r2rX, Please provide reproduction steps in details , nvidia bug report. Is this issue with WINE, Steam ot Pure Linux OS ? What desktop env you are running like gnome, kde, unity etc. ?

i can say that i have this exact issue with other native unreal engine 3.# games such as sanctum2 or papo & yo.
this raster blighting - i think its called- even appears with MESA or nouveau, however it is not present on unreal 3 games through WINE.
odd to be sure

Looks like then this issue Opengl issue. Wine might be using directX . Did you reported this to Game developments ? Also did you test with any other nvidia driver versions?

Also attached log of user (ready2rumbelx@gmail.com )

(after) nvidia-bug-report.log.gz (209 KB)

(during) nvidia-bug-report.log.gz (212 KB)

My sincerest apologies for not having replied until now. The version of the game referenced here is the native version of Borderlands 2 (not WINEd).

To reproduce this bug, simply enable Anisotropic Override (and choose any value from the slider) and enable Texture Sharpening from the 'Antialiasing Settings from the NVIDIA X Server Settings.

The first screenshot I posted was with both AA Override and Texture Sharpening On. The second screenshot is only with Texture Sharpening enabled. If both AA Override and Texture Sharpening are disabled, there are no graphical issues.

From experience with Painkiller and Borderlands 2 (native Linux versions, not WINE), they both suffer the same graphical issue under the same conditions. I’d assume it has to do with the Unreal Engine 3 renderer and the NVIDIA driver.

Edit: Concerning my Linux environment, it’s Linux Mint 17 MATE edition, using the NVIDIA 343.22 driver and Compton as my compositor (although the issue at hand is not affected by Compton being enabled or disabled). I’ve also tested in Arch Linux using KDE and the issue is the same. This also spans across multiple driver revisions (although I can’t tell you which was the first driver version I noticed this on…but during the last year or so).

I can confirm happens on my system also.
on PK:HD Native from Steam.

Repro:

  1. In nVidia settings override Anisotropic Filtering 1-16x on the slider

1-2x

4x

8x

16x

System
Archlinux 3.16.6-3-ck
KDE desktop with kwin.
nVidia 343.22
nVidia Zotac GTX 670 AMP!

Internally tracking this issue under Bug 200051040 .

edited. Does it repro with any UE4 demo/game?

thanks for the PM,
i was able to reproduce this on the Intel driver while experimenting with the debug settings in driconf
http://dri.freedesktop.org/wiki/DriConf
although this was with an older version of the the driver and driconf, the setting may have been removed
despite repeated testing i was unable to reproduce with my current setup, but with more knowledge of /etc/dirc you could be able to force anisotropy through that config file?

i wish i could be more helpful

would contacting Felix Kuehling (developer of driconf) be useful?

I tried it on Unreal Tournament 4 alpha with -opengl4 param and it was running fine other than the known bloom issues.

We’ve investigated and this is a bug in the application. Closed bug.

So this is a bug that is identical in both Painkiller and Borderlands 2?

Edit: Nothing to do with the drivers?

Both use the Unreal Engine 3, which has this bug. I have seen this bug in just about any UE3 game. You get the same in Sanctum 2 aswell.

Just to let everyone interested know, this anomaly doesn’t seem to be restricted to UE3 engine titles…this is also occurring in Trine Enchanted Edition. It isn’t happening to Trine 2, though.

This happens with both the 343.22 and 346.16 drivers.

May I ask why you’re setting AA in the nvidia-settings control panel anyway? those settings should be handled by the game engine IMO. That’s why settings for AA and others are there to manipulate in game. This is just my 2 cents. It’s most likely caused because you set the AA in the nvidia control panel which affects everything but then you launch a game and set a different AA so clearly the 2 are conflicting and causing the bug.

It’s Anisotropic Filtering that causes this…not Anti-Aliasing. :) The principle however might be the same…but this doesn’t happen in most other titles available on Linux (or Windows).

maybe the titles it doesn’t occur in either ignore global AA and AF settings and use their own OR they don’t set AA and AF themselves and use the global settings. Most games developed these days have AA and AF settings which are configurable so I see no reason to ever set AA and AF on a global basis using nvidia-settings but just is just my opinion.

Was this bug ever fixed? This is how Sanctum 2 looks when both AF and texture sharpening are enabled: