High quality texture filtering is not applied automatically

With recent drivers (e.g. 495.44), set texture filtering to high quality in nvidia-settings and restart the system. Then start e.g. Strange Brigade via Stream Proton with vsync off. In the main menu, Steam Overlay’s fps counter reports ~146fps (RTX 3060 in 1440p). Close the game and open nvidia-settings again. Set quality from HQ to Q and back to HQ. Start the game again: Now fps counter reports ~142fps instead. Conclusion: HQ texture filtering setting is not applied without switching to it first in the same Xorg session.

Side note: HQ texture filtering quality with negative LOD bias is worse with Vulkan vs. Windows D3D10/11/12. You can test this with 3DCenter Filter Tester (load ground2 texture from its program dir) by running it with DXVK (32 bit version, requires Wine build with Vulkan child window support on Linux, but you can also test it on Windows):

DLSS developer guidelines recommend setting a negative texture LOD bias, so it would be nice if this was improved in the Nvidia Vulkan driver (on both Windows and Linux).

On login, nvidia-settings -l has to be run once for the saved settings to apply.

Thanks, that indeed is the issue. It’s a bit confusing, as display color settings are also applied without it.

Actually, also display color settings aren’t applied without it. Annoying, as nvidia-settings -l resets GPU gamma ramps. I’d call this behavior undesired and thus bugged. :(

color settings are applied to colord/xorg, so are saved in system settings in contrast to nvidia graphics driver settings. The color reset bug is long standing, rather report a bug here:

I tried with dithering setting, it wasn’t applied without nvidia-settings -l.

dithering is a driver setting.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.