[SOLVED] Metro Redux driver 346.xx Very High Quality glitch

Given the launch of Metro 2033 Redux and Metro Last Light Redux for Linux, I got them and I’m having an issue.
At least in driver 346.16 and 346.22 I see a glitch that “smears” the shaders/textures all over the place when Quality: “Very High” is selected.

Rolling back to 343.36 or selecting Quality: “High” does not exhibit the issue.

Some pics: Metro Redux Linux nVidia bug 346.xx - Album on Imgur
Pic 1: the menu here you select Quality
Pic 2: main game screen for Metro 2033 Redux after the logo movie (the one with press a key to continue) with 343.36 on “Very High”
Pic 3: same screen as Pic 2 but with 346.16/22 on “Very High”
Pic 4: a random screen grab on the first mission in Metro 2033 Redux that exhibits the issue
Pic 5: a random screen grab on the first mission in Metro Last Light Redux that exhibits the issue

I’ll generate a debug log if one is requested.

GTX660 Ti on Debian Sid 64bit, kernel 3.17, X

I can confirm this also on GTX 970 and 346.22

This is how it looks for me on Very High:

Linux 3.17.6-ck
nvidia 346.22 @ MSI GTX 970 Gaming
KDE 4.14 with Kwin
Steamsysteminfo: Steam System information · GitHub


  1. Launch the game and change video settings to “Very High”
  2. Restart game to make the settings take effect.
  3. Launch game
  4. Notice that in cut-scenes (game intro or even game menu) not the video and nvidia logo the game will do that smear effect as described by OP. Also quite noticeable when starting first level in game.
    nvidia-bug-report.log.gz (29.8 KB)

No need to restart, at least in Metro 2033 Redux, exit the Options menu and move the mouse around, the glitch appears on the left side, between the Options and the scene margins.

Same issue here on Arch with 346.22. Luckily UT4 is less buggy with this set at least.

Edit: 343 series is fine for those who just want to play the game and see this post. 343’s also crash less when gsync mode flips on and off.

same here on 346.22 with kubuntu 14.10 64b and xorg:edgers.

only the texture glitch on very high settings though. i have not experienced any other bugs or glitches.

Same here on 364.22 with opensuse tumbleweed 64bit.

Performance wise, the 364.22 is faster than 343.x . For me its is 126 fps to 116 fps in high settings.


any news for nvidia on this issue ? The metro redux titles are one of the few aaa titles for linux right now, having them working correctly is really necessary.

Could you reproduce the issue internally ? Is there already filed a bug for this ?

Many thanks,

Is the bug still there with 346.35?
It’s still not in Arch repos so I can’t test it for myself…

Nice, thanks for the info, didn’t notice that a new 346.x driver was released. An indeed, it looks like they fixed it. great !

Upgraded to 346.35 from 343.36, I can confirm that the game is exactly the same, just renders smoother with around 5-10 more FPS on GTX 660.

Bug fixed in 346.35.

/thread closed