[Vulkan] Texture flickering on Mad Max with 396.24, 390.59 is fine.

Tried on a gtx 1060 and a gtx 750ti, the same happens.
Anybody can confirm? look at the main character,it is not blood, but the texture flickering red.
Mad Max running in Vulkan mode:

nvidia bug report:
nvidia-bug-report.log.gz (155 KB)

Do you always see this glitch or do you have to do something particular in game or go to a specific level?

Yes, i think it is always, because if you pay attention, is even visible on the skin of the characters since the intro.
I tried on 2 different systems, both running arch linux.

Could you share the graphics settings you are using in game?

Double post

As for the graphics settings, i even tried to put all things down to low, no change.
i use different graphics settings on the systems, so i don’t think it is related.
If you still need them, i can post it tomorrow.

I tried a couple of things:

  • put out VGA=775 from bootloader
  • used nvidia_drm modeset=1 module option
  • tried both fullscreen and window mode
  • switched Option “UseNvKmsCompositionPipeline”
  • tried with and without steamoverlay
  • disabled allow flipping in nvidia-settinga
  • with and without forcefullcompositionpipeline
  • switching in game vsync

Nothing worked ; now i just Reverted to 390.59 and it “fixed” the issue.

Well, one month passed.
Any news on this?
Did you devs tried to reproduce the issue? Did you succeeded?
Workarounds/internal tracking… something?


I don’t have that issue. I’m on Jeet’s Stronghold as well but that issue not exists.

Nvidia Driver 396.24.02 - GTX 1050 4 gb + Intel Hd ( Nvidia Prime )

I’m playing on high preset.

Are you sure you’re using the madmax vulkan beta?
livelongandprosper in steam to enable it…

Yes. I’m sure.

On Feral Launcher , Vulkan ( Experimental ) is also selected. Fps smoothing is disabled.

I haven’t been able to reproduce that bug so far. :(

I don’t know what to say.
I’m able to reproduce on two systems, both running arch linux.
They share the same motherboard model, but have two different gpu; one 1060, the other 750ti.

Today i fully updated arch, made another brand new user installed just steam and madmax, and still, the texture are flickering.

However, according to nvidia-settings, i’m running 396.24; not 396.24.02.


Well, since there is no way for my to use 396.24.10 through arch, i tried 396.24.10, and texture are fine.