WinXP 64-bit CUDA samples compiling cutil32.lib --> cutil64.lib?

Hey guys,

Just installed CUDA suite (drivers, toolbox and SDK) under 64 bits Windows XP. I made sure I choose the 64 bits versions of all files. Then I downloaded a simple sample (the histogram) and tried to build.

The .obj-file generated from the .cu-file is 64 bits (because of the version of nvcc and later-stage compilers). So I had to change the target environment of the project to “x64”. This makes sense since the sample was written before 64-bit drivers were released. But then I ran into another problem, one I cannot fix. It seems like the utility functions such as “cutCreateTimer” are only implemented in a 32-bit library (namely cutil32.lib/.dll). This file is shipped with the sample and there is no cutil64.lib/.dll shipped with the 64-bit drivers.

So… does there exist a 64-bit version of cutils? I have been googling for a while now and it doesn’t look like it. Yet some posters claim to be able to compile the samples without any much trouble under windows xp 64 (although it seems their compilers still were 32 bits). See for example: http://forums.nvidia.com/index.php?showtopic=28716 (note: this discussion is more than a year old).

The thing is, I have been developing a CUDA application on 32-bits windows XP for a while now, and recently bought a new pc and, to use the large amount of RAM, I needed a 64 bits OS. I use some cutil functions (timing and initialization/exiting), but could do without, but that would require some extra work (use getTickCount, for example), finding a 64-bit implementation of the utility functions would be much better.

Thank you for reading and I hope that some of you have some experience with this. :)

Sorry guys, found it after reinstalling the SDK.

Location: bin\win64\Release\cutil64.dll

:"> Sincere apologies