CUDA 4.0 and Visual Studio 2008

Hello,

i’m using the last CUDA 4.0 toolkit and Visual Studio 2008 professional (for Windows 7 64 bits).
I can run NVIDIA GPU Computing SDK 4.0’s examples, but when i want to build a .cu file or project in Visual Studio 2008 i get an error.
I tried re-insatll Cuda toolkit after visual studio (for the rules to copy right) but it’s still the same …

What should i do ?

edit : it cant find cutil64d.lib

Please i need your help.
I installed VS2008, the last driver, the last toolkit 64 bits, sdk samples 64 bits. And i can’t launch a sample without this “cannot open input file ‘cutil64D.lib’” error.
I tried to add additional directories and dependencies, but nothing work … i already reinstalled 2 times …

edit : ok i was desperated so i installed cuda 3.2 instead. (and sdk samples 3.2)
now i’m able to build and run the samples.
But when i want to run another .cu (here the “sample.cu” of the “CUDA VS Wizard” project) they told me “cutil64d.dll missing” whereas i can build it successfully …
So i believe it’s not a good way to create a project …

I can i add my simple “Hello world” cu file to a new project please ? (i know how to create a new cpp files but there’s no cu files in a “new item” list so …

Hi,

I had the same problem, missing ‘cutil64d.dll’.
You have to build ‘cutil_vs2008.sln’ in debug/release, win32/x64.
I found this solution in ‘c:\ProgramData\NVIDIA Corporation\NVIDIA GPU Computing SDK 4.0\CUDALibraries\common’ folder.

Hope it helps.

Hello there,
cutil64d.lib is for debug mode and cutil64.lib is for release mode… you should add lib path of GPU Computing SDK (at the moment I have not installed it on my machine then I cannot post full path :P) under Likner->General->AdditionalLibraryDirecotry and add cutil64d.lib or cutil64.lib under Linker->Input->AdditionalDependencies; this is all ;-)

Edit
If you want to create new project like Hello World you do not need cutil lib because it is used only in sample of GPU Computing SDK, read this http://llpanorama.wordpress.com/2008/05/21/my-first-cuda-program/ to start build your project in Visual Studio

Hmm. I have seen the answer about building the VS2005 or 2008 files, however I am not finding either of the .sln’s. I have installed (and re-installed) the 4.0 toolkit and tools msi files, and even dropped back to 3.2. I am not getting that directory. I have also searched my drive for the files, just in case… Any idea which installer contains these files? I am missing something obvious here…

Thanks!

(Edit… Well, finally figured out the obvious, and pulled down the correct file for the sdk… that is where they reside)

The SLN files are Visual Studio Solution files and they are in the folder mentioned above.

I will type which folder they are in for me, I’m using 4.0 and on Vista. I have installed the 3 things which Nvidia say, they’re on the main CUDA download page.

The folder is C:ProgramData/Nvidia Corp/Nvidia GPU Comp SDK 4.0/C/Common and there you’ll see the files, look for the files with the .sln extension, cutil_vs2005.sln, cutil_vs2008.sln and in my case cutil_vs2010.sln too.

If you don’t have them even after re-install contact Nvidia.

I can’t help with anything else because I’m a beginner too.