WSL2 flashing with NVIDIA SDK Manager

Hi,

I’m sorry but our documents only verifies cases with AGX Orin, which is to be flashed internally with flash.sh. For Orin NX/Nano that requires initrd flash, we don’t validate such use cases.

Anyway, seems like WSL kernel you use does not enable the bonding driver, which is required in the case of initrd flash.
For example, this is enabled on my Ubuntu 18.04 PC

davey@dave-yu-nvidia-pc:~/Downloads$ cat /boot/config-$(uname -r) | grep BONDING
CONFIG_BONDING=m

I’m not sure why it’s not there because it should be enabled by default:

You may enable that driver and build the kernel again to see if it solves the issue.