X server loads properly but there is only black screen

When I boot OS, there is no login screen - only black screen. I can work in terminal, but when I switch to X server the screen freezes. I use xubuntu 12.10 with lightdm. When I check lightdm logs, it says that the lightdm loaded properly and switched to X server, but I cannot see it. I have Asus N55S with intel card and nvidia GT 555M card.

I had several other problems with the driver. I had to specify BusId, ConnectedMonitor and I had to create custom EDID file for my monitor. Now I can at least run the driver, but still doesn’t work.

Thanks to anyone who could help!
nvidia-bug-report.log.gz (106 KB)

This is an Optimus-based laptop. It’s likely that the screen in it is not actually connected to the NVIDIA GPU, so faking it with ConnectedMonitor won’t help. Does the screen appear correctly if you use the intel driver instead of the nvidia driver?

You do have an Xorg.1.log in your bug report log that indicates that the intel driver did load correctly and detect a 1600x900 flat panel.

Display works properly with intel driver.

Okay, I figured that out.

I installed Bumblebee, reinstalled nvidia driver and now it works!