Xavier NX 16GB Jetpack 5.0.2 Flash NVMe

So I was able to get SDKManager to install Jetpack 5.0.2 to NVMe SSD on Xavier NX… it did not work on several tries… but then I switched to a VM running 18.04 and it worked.

However, while it now works… for some reason, the onboard eMMC does not show up as a device. I am using a SeeedStudio carrier board that does not have and SDCard interface.

After the flash, the JetPack seems to work okay, but I am seeing what I think are odd things in the configuration. Running lsblk shows a number of portions on the NVMe device as follows:

NAME         MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
loop0          7:0    0    16M  1 loop 
zram0        251:0    0   1.8G  0 disk [SWAP]
zram1        251:1    0   1.8G  0 disk [SWAP]
zram2        251:2    0   1.8G  0 disk [SWAP]
zram3        251:3    0   1.8G  0 disk [SWAP]
nvme0n1      259:0    0 465.8G  0 disk 
├─nvme0n1p1  259:1    0 465.2G  0 part /
├─nvme0n1p2  259:2    0    64M  0 part 
├─nvme0n1p3  259:3    0    64M  0 part 
├─nvme0n1p4  259:4    0   448K  0 part 
├─nvme0n1p5  259:5    0   448K  0 part 
├─nvme0n1p6  259:6    0    80M  0 part 
├─nvme0n1p7  259:7    0   512K  0 part 
├─nvme0n1p8  259:8    0   300M  0 part 
├─nvme0n1p9  259:9    0    64M  0 part 
└─nvme0n1p10 259:10   0    18K  0 part

Notice there is no eMMC device listed. Running lsblk with -f option shows the following format types…

NAME         FSTYPE LABEL      UUID                                 FSAVAIL FSUSE% MOUNTPOINT
loop0        vfat   L4T-README 1234-ABCD                                           
zram0                                                                              [SWAP]
zram1                                                                              [SWAP]
zram2                                                                              [SWAP]
zram3                                                                              [SWAP]
nvme0n1                                                                            
├─nvme0n1p1  ext4              7f4f3c24-7f8f-4544-8cc0-765edbd7de43  421.3G     4% /
├─nvme0n1p2                                                                        
├─nvme0n1p3                                                                        
├─nvme0n1p4                                                                        
├─nvme0n1p5                                                                        
├─nvme0n1p6                                                                        
├─nvme0n1p7                                                                        
├─nvme0n1p8                                                                        
├─nvme0n1p9  vfat              7F76-CC3A                                           
└─nvme0n1p10

Partitions 3 through 8 and 10 show now format type. Running fdisk -l shows the following for the NVMe drive:

Disk /dev/nvme0n1: 465.78 GiB, 500107862016 bytes, 976773168 sectors
Disk model: Samsung SSD 970 EVO Plus 500GB          
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 5A500A9A-5CE3-4D39-BC01-05612C87A207

Device            Start       End   Sectors   Size Type
/dev/nvme0n1p1  1174352 976773128 975598777 465.2G Microsoft basic data
/dev/nvme0n1p2       40    131111    131072    64M Microsoft basic data
/dev/nvme0n1p3   131112    262183    131072    64M Microsoft basic data
/dev/nvme0n1p4   262184    263079       896   448K Microsoft basic data
/dev/nvme0n1p5   263080    263975       896   448K Microsoft basic data
/dev/nvme0n1p6   263976    427815    163840    80M Microsoft basic data
/dev/nvme0n1p7   427816    428839      1024   512K Microsoft basic data
/dev/nvme0n1p8   428840   1043239    614400   300M Microsoft basic data
/dev/nvme0n1p9  1043240   1174311    131072    64M EFI System
/dev/nvme0n1p10 1174312   1174347        36    18K Microsoft basic data

The other odd behavior is that after the flashing, it goes through a number of boot options before actually booting from NVMe. I was able to use efibootmgr to set the boot order to the NVMe drive but there are a number of other options listed and no eMMC option.

BootCurrent: 0001
Timeout: 5 seconds
BootOrder: 0001,0006,0005,0004,0003,0002,0000
Boot0000* UiApp
Boot0001* UEFI Samsung SSD 970 EVO Plus 500GB S58SNM0T701639V 1
Boot0002* UEFI PXEv4 (MAC:48B02D6783B0)
Boot0003* UEFI PXEv6 (MAC:48B02D6783B0)
Boot0004* UEFI HTTPv4 (MAC:48B02D6783B0)
Boot0005* UEFI HTTPv6 (MAC:48B02D6783B0)
Boot0006* UEFI Shell

The original boot order (after flashing) was set as follows:

BootOrder: 0005,0004,0003,0002,0001,0000,0006

So my questions…
(1) Are the 10 partitions on the NVMe drive supposed to be there?
(2) Why is there no eMMC device listed?
(3) Is the boot order options expected?

Hi,

Could you share me the dmesg?

Hi @WayneWWW I have attached the dmesg log. It does seem to boot up okay, but it does show some errors and other odd stuff in the dmesg stream… or at least what looks odd to me. I can’t decipher most of it…lol.

dmesg-boot.txt (68.4 KB)

Hi,

Why do you say it does not boot okay? There is no error here. Only one point here is the emmc seems not getting enuerated.

Could you also use flash.sh to flash emmc case and see if it can work?

Sorry, yes, it does boot okay. I will try the flash.sh script and see what happens.

The only odd behavior is that occasionally, when I try to use apt to install a package, it will give a warning about not recognizing the disk type, but it still seems to work.

Also, are the 10 partitions on the NVMe drive expected behavior?

Yes, it is expected.

For a starter this board have been a headache, thanks to you i tried upgrade to jetpack 5 and after using flash of 32.7.1 i got the board booting and now it runs 5 and i don’t understand still running 5 i’m now loading the SDKs , but i have now worked about 6 full days out of dailywork hours to get this running , what a wast of time if i didn’t whant to show up as a misstake engineer. This board is not compatible with mine little brain still i bought a installed board from seed…