SDK Manager thinks two Jetson Xavier NX connected, but only one is - can't flash board

I have a Jetson Xavier NX module (Jetson SUB Mini PC-Silver with powerful Jetson Xavier NX module, aluminium frame enclosure, 128GB SSD, WIFI, antennas and pre-installed JetPack system.(Ready to use) - Seeed Studio), which I have previously been able to flash Jetpack 5.0.1 to with no issues (both to EMMC & NVMe). My host OS is Ubuntu 20.04. Yesterday I tried to flash Jetpack 5.0.2 to Xavier’s NVMe and this has taken me down a very frustrating rabbit hole. At first the flash of 5.0.2 kept failing, so I uninstalled everything from EMMC & NVMe (using GUI SDK Manager). Then I systematically installed 5.0.1 to EMMC (worked), then 5.0.2 to EMMC (worked), then 5.0.2 to NVMe. The latter “worked” in the sense that the flash completed successfully (according to SDK Manager)…however, when I connected a monitor to the Xavier to do the initial Ubuntu setup I just see a black screen. I also trieded to ssh to Xavier ( but it just hung. So when I opened the GUI SDK Manager back up the first thing I get is a pop-up window saying "SDK Manager detected device connected. Please select the target hardware for (USB port: 1-3 Bus/Device: 001/010): " and it presents two options: Jetson Xavier NX and Jetson Xavier NX [developer kit version]. This is the first time I’ve ever seen it do this, and seems no matter what I do it continues to see two devices (even though there is only one device connected). The board in this housing is not a developer kit version, so I’m not sure where this second option is coming from. I have tried using other USB ports on my laptop and even tried rebooting the laptop - still the same thing. I’ve also tried flashing 5.0.2 via the Jetson linux flash container (Jetson Linux Flash container | NVIDIA NGC), but I get an error part way through the flash when I try this: “Skip generating EFI system partition image. EFI system partition image (esp.img) not found.”

This is driving me nuts - any help would be greatly appreciated.


Please stop trying anything further and just answer the questions here first. Need to clarify the situation.

  1. So this is a custom board from Seeed Studio but not jetson developer kit?

  2. So this issue only happened if you flash with nvme?

  3. Does the board vendor (Seeed Studio) provide any method to check log in serial console? This is to check log when monitor is dead.

Hi Wayne,

Thank you for your response.

  1. Yes, it looks to be a custom carrier board with a Jetson Xavier NX attached (see image here).

  2. I think the issue was more that I flashed 5.0.2 to EMMC and then - without uninstalling from EMMC - I also flashed 5.0.2 to NVMe. I’m not sure the problem was specifically just NVMe (other than the initial error when trying to flash 5.0.2 to NVMe, as I previously mentioned).
    As an aside on this, another thing I tried was to remove the 128GB SSD (NVMe) from the carrier board. I wanted to see if the two separate installs of the OS (to EMMC & NVMe) were causing the board to be seen as two separate boards. This also did not work - SDK Manager still saw two boards, even with the SSD removed from the carrier.

  3. I am not sure about this and will have to check with Seeed Studio and post another response…

Are you sure your board is really in recovery mode?

Could you remove every cable between your host and jetson and leave only the micro usb cable to flash?

I’ve already tried doing that. I’ve also placed a jumper on the force recovery mode pins just to make sure and that did not work either.

The board vendor provided a link to instructions on how to check the log in a serial console:

I’m unsure if for this particular board the method requires purchasing / using the items shown at the bottom of the page (since the instructions are for a different device). Waiting for a response from the vendor on that…

The problem was solved by uninstalling all previous OS installs from the Xavier NX (nothing was appearing in the repair / uninstall list previously for some reason), then installing 5.0.2 to NVMe, then 5.0.2 to EMMC. Then changed the boot order to prioritize NVMe, as per the video here: Jetpack 5.0.2 Boot from NVME Drive for Seeed Studio J202 carrier board with Jetson Xavier NX module - YouTube

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.