Xavier NX booting issue after updating jetpack 4.4 to jetpack 5.0.2

Hello,

I tried to upgrade 5.0.1 to 5.0.2 and it didn’t rebooted !!!

I did this but didn’t work for me :

https://jetsonhacks.com/2022/08/20/upgrade-jetpack-5-to-production-version/

And this :

https://www.seeedstudio.com/blog/2022/08/17/jetpack-5-0-2-production-quality-release-is-live-now/

ok, Then I suggest to flash the SD card or eMMC first. after that follow instructions from https://github.com/dusty-nv/jetson-inference.git to transfer the system to SSD.

it works for me. Hope this would work for you too!

Will try this tonight

https://forums.developer.nvidia.com/t/managed-to-flash-jetson-xavier-nx-custom-board-with-jp462-not-jp502/228310/4?u=gagipro

Hi,
I have the same question as above,

where is the “jetson-xavier-nx-devkit.spi.img” file which is needed for the step sudo flashcp jetson-xavier-nx-devkit.spi.img /dev/mtd0 ?

Please help me.

1 Like

Moreover, if I try to extract the QSPI file “Jetson_Xavier_NX_QSPI_35.1.gz”, it seems to be not in a valid gzip format. I have downloaded the file on Windows/Ubuntu/Debian on 4 different machines with 2 different Internet connections. Everytime it is around 15MB in size but not in a gzip format (bad format). Please let me know how to get the jetson-xavier-nx-devkit.spi.img file which is needed to be flashed.

1 Like

Hi are you having bad time flashing nx through gui and no issue with 5.0.1 also ?

Yes. I followed the below procedure to reflash the board. There are some pre-req for the host machine which are not mentioned in the guide (qemu installation and libxml requirement), but overall this is the process which worked for me smoothly.

I don’t know where to download specific image files, but normally such a thing would be with the specific L4T release page:
https://developer.nvidia.com/linux-tegra

So far as the file being invalid, under Linux, what do you see from:
file Jetson_Xavier_NX_QSPI_35.1.gz