Xavier NX not booting after trying to upgrade the jetpack from 4.6.2 to 5.0.2

Hi,

I tried to upgrade the jetpack from 4.6.2 to 5.0.2 using the SD card image method in Xavier NX by following the instructions in the following link:

Here are the steps that I followed:

  1. Downloaded QSPI image (Jetson_Xavier_NX_QSPI_35.1.gz) to the xavier nx that was running on jetpack 4.6.2 and followed the instructions given in the following link

https://docs.nvidia.com/jetson/archives/r35.1/DeveloperGuide/text/SD/FlashingSupport.html?highlight=upgrade%20jetpack#to-upgrade-jetpack-4-x-to-jetpack-5-x-on-jetson-xavier-nx-p3668-0000

QSPI image download link:
https://developer.nvidia.com/embedded/L4T/r35_Release_v1.0/QSPI-img/Jetson_Xavier_NX_QSPI_35.1.gz

a) I tried to write a QSPI image into the QSPI device with the following commands:
$ sudo flash_eraseall /dev/mtd0

$ sudo flashcp jetson-xavier-nx-devkit.spi.img /dev/mtd0
<This command said that there’s no “jetson-xavier-nx.spi.img” file>
So I tried replacing this image file with the downloaded image file in the same command
$ sudo flashcp Jetson_Xavier_NX_QSPI_35.1.gz /dev/mtd0
<This command didn’t throw any error. Seemed to run properly>

b) I tried to use manual QSPI generation steps:

  • Downloaded the Jetpack 5.x BSP package and extracted it to the nx
    $ cd Linux_for_Tegra
    $ sudo BOARDID=3668 FAB=300 BOARDSKU=0000 BOARDREV=1 FUSELEVEL=fuselevel_production CHIPREV=2 ./tools/l4t_generate_jetson_xavier_nx_qspi_images.sh -b jetson-xavier-nx-devkit
  1. Unplugged SD card, formatted and flashed 5.0.2 image file in the SD card

  2. Inserted SD card with a new jetpack to NX. It didn’t boot up. I can see the power light getting turned on but no display or booting up.

  3. I tried reflashing the SD card with the previous jetpack version and still the same problem persists. Still not booting up and no display.

Please help me resolve this issue.

Thanks,
Durga

Hi,

I am not sure if you are willing to try just another easy way.

Please directly flash your board with sdkmanager and it would work… Basically, it is doing the same thing as what you are trying.

Also, is your “not booting” indicating “really not booting as you already checked the serial log” or just “no display so you are not able to tell whether it is booting up”?

Hi,

Xavier NX developer kit is working now! We followed the flashing instructions using the container with the NVIDIA team’s support (As per the below link)

https://catalog.ngc.nvidia.com/orgs/nvidia/containers/jetson-linux-flash-x86

To answer your questions, we checked the serial console, but there was no output and no signals in the oscilloscope as well. Also, the SDK manager didn’t work for some reason. But finally, the flash container method worked.

Thanks,
Durga