Xcode Installation Issues

Hello,

When I tried to build the Optix’s sample code from Xcode (Version 8.3.1) I get the following error:

nvcc fatal : The version (‘80100’) of the host compiler (‘Apple clang’) is not supported

CMake Error at cuda_compile_ptx_generated_phong.cu.ptx.cmake:245 (message):
Error generating
/Developer/OptiX/SDK/buildT/lib/ptx/cuda_compile_ptx_generated_phong.cu.ptx

make: *** [/Developer/OptiX/SDK/buildT/lib/ptx/cuda_compile_ptx_generated_phong.cu.ptx] Error 1
Command /bin/sh failed with exit code 2

So nvcc complains about an unsupported host compiler version.
That normally means the CUDA Toolkit you used either doesn’t know of a newer host compiler or doesn’t support an older host compiler anymore.

Check which CUDA Toolkit you used and what its documentation says about supported host compilers.
The latter information can be found inside the per OS documents named CUDA_Installation_Guide_.pdf inside the CUDA doc/pdf folder

For example the CUDA 8.0 CUDA_Installation_Guide_Mac.pdf says on page 2 it supports Xcode 7.3 only.
Means your host compiler is too new.

Thank you for your fast response.

I will re-install Xcode 7.3, and looking forward for support on Xcode 8.3.1.

Thanks

hi Detlef,

i’m also trying to install onto a MBP running 10.12,
and with Cuda compilation tools, release 8.0, V8.0.61

but looking at the system requirements table here
http://docs.nvidia.com/cuda/cuda-installation-guide-mac-os-x/index.html#system-requirements
made me believe it should work with my currently installed XCode 8.3.1?

but i continue to get the same error, “The version (‘80100’) of the host compiler (‘Apple clang’) is not supported”

are the sys requirements above inaccurate, or am
i just reading that table wrong? do i still need to go back to Xcode 7.3?

thanks for your help, Rik

But the table you linked to says Xcode 8.2 and Apple LLVM 8.0.0 under Mac OS X 10.12, not Xcode 8.3.1 and LLVM 8.1.0(?) as the error message seems to indicate.

Here are the more detailed release notes for Mac OS X linked on that site, saying Xcode 8.2.1 is supported:
http://docs.nvidia.com/cuda/cuda-toolkit-release-notes/index.html#axzz4iSY1PGm1

Sorry, I need to pass on Mac OS X questions apart form citing existing documentation. I’m not using OS X myself.

thanks Detlef. yes, i had noticed the differences in minor release numbers, but was trying to be optimistic about the basic Xcode v8.x with CUDA v8.x operability; that the issues now seem to have
to depend on these minor variants is discouraging.

are there other NVIDIA moderators whose attention i might be able to get on the Mac OS X platform?
i’m trying to be prepared for a NVIDIA class (https://www.eiseverywhere.com/ehome/236672) and i have to believe others will have the same issues.

I recently dealt with the same problem. It’s not hard to solve, and you don’t have to revert to Xcode 7.3.

You can follow the advice from StackOverflow that I’ve copied here:

  1. Go to https://developer.apple.com/downloads/, log in and then download http://adcdownload.apple.com/Developer_Tools/Command_Line_Tools_OS_X_10.11_for_Xcode_7.2/Command_Line_Tools_OS_X_10.11_for_Xcode_7.2.dmg, and install, as was suggested by fabregaszy.
  2. Run the following command to switch to the old version: sudo xcode-select --switch /Library/Developer/CommandLineTools
  3. Run the following command to quickly check clang version: clang --version

My addition to these instructions: If you are using CMake, then you can just install the command line tools in step 1 and set the compiler for NVCC to use there instead of doing steps 2 and 3, so you don’t even need to be an administrator on your machine.

Does anyone know the date we will have an update, like CUDA 9 or something, that supports the newer LLVM provided with Xcode ? I have Apple LLVM version 8.1.0 (clang-802.0.42) and Cuda compilation tools, release 8.0, V8.0.54 installed.

Thank you.

Yes, I’m really waiting for a CUDA 8 update that supports Xcode 8.3.3!! Please NVIDIA release it! :-)

Waiting for support for Xcode 8.3.3 and OSX 10.12.X

Have supported for Xcode 8.3.3 or Xcode9 and OSX 10.12.6? What version CUDA should I download?