Optix Tookit does not build

I installed optix 8,0 and I am compiling the exampĺes fine. I was suggest to install optix Apps. So I downloaded optix toolkit and tryed to build it. I got a strange error that it does not support the nvcc compiler.

Thank you,
Rafael

Running vcpkg install
Detecting compiler hash for triplet x64-linux...

All requested packages are currently installed.
Total install time: 423 ns

glad provides CMake targets:

  # this is heuristically generated, and may not be correct
  find_package(glad CONFIG REQUIRED)
  target_link_libraries(main PRIVATE glad::glad)

glfw3 provides CMake targets:

  # this is heuristically generated, and may not be correct
  find_package(glfw3 CONFIG REQUIRED)
  target_link_libraries(main PRIVATE glfw)

imgui provides CMake targets:

  # this is heuristically generated, and may not be correct
  find_package(imgui CONFIG REQUIRED)
  target_link_libraries(main PRIVATE imgui::imgui)

rply provides CMake targets:

  # this is heuristically generated, and may not be correct
  find_package(rply CONFIG REQUIRED)
  target_link_libraries(main PRIVATE rply::rply)

The package stb provides CMake targets:

    find_package(Stb REQUIRED)
    target_include_directories(main PRIVATE ${Stb_INCLUDE_DIR})
imath provides CMake targets:

  # this is heuristically generated, and may not be correct
  find_package(Imath CONFIG REQUIRED)
  target_link_libraries(main PRIVATE Imath::Imath Imath::ImathConfig)

openexr provides CMake targets:

    find_package(OpenEXR CONFIG REQUIRED)
    target_link_libraries(main PRIVATE OpenEXR::OpenEXR)

The package gtest is compatible with built-in CMake targets:

    enable_testing()
    
    find_package(GTest CONFIG REQUIRED)
    target_link_libraries(main PRIVATE GTest::gtest GTest::gtest_main GTest::gmock GTest::gmock_main)
    
    add_test(AllTestsInMain main)


Running vcpkg install - done
Found CUDAToolkit: /usr/include (found version "11.5.119")
Found CUDAToolkit: /usr/include (found suitable version "11.5.119", minimum required is "11.1")
CMake Error at CMake/embed_cuda.cmake:108 (set_property):
  CUDA_OPTIX_COMPILATION property is not supported by NVIDIA compiler version
  11.5.119.
Call Stack (most recent call first):
  DemandLoading/DemandLoading/tests/CMakeLists.txt:122 (embed_cuda)


CMake Error at CMake/embed_cuda.cmake:108 (set_property):
  CUDA_OPTIX_COMPILATION property is not supported by NVIDIA compiler version
  11.5.119.
Call Stack (most recent call first):
  OmmBaking/tests/CMakeLists.txt:34 (embed_cuda)


CMake Error at CMake/embed_cuda.cmake:108 (set_property):
  CUDA_OPTIX_COMPILATION property is not supported by NVIDIA compiler version
  11.5.119.
Call Stack (most recent call first):
  ShaderUtil/tests/CMakeLists.txt:105 (embed_cuda)


CMake Error at CMake/embed_cuda.cmake:108 (set_property):
  CUDA_OPTIX_COMPILATION property is not supported by NVIDIA compiler version
  11.5.119.
Call Stack (most recent call first):
  examples/Simple/OtkHello/CMakeLists.txt:38 (embed_cuda)


CMake Error at CMake/embed_cuda.cmake:108 (set_property):
  CUDA_OPTIX_COMPILATION property is not supported by NVIDIA compiler version
  11.5.119.
Call Stack (most recent call first):
  examples/CuOmmBaking/Viewer/CMakeLists.txt:35 (embed_cuda)


CMake Error at CMake/embed_cuda.cmake:108 (set_property):
  CUDA_OPTIX_COMPILATION property is not supported by NVIDIA compiler version
  11.5.119.
Call Stack (most recent call first):
  examples/DemandLoading/DemandGeometryViewer/CMakeLists.txt:40 (embed_cuda)


CMake Error at CMake/embed_cuda.cmake:108 (set_property):
  CUDA_OPTIX_COMPILATION property is not supported by NVIDIA compiler version
  11.5.119.
Call Stack (most recent call first):
  examples/DemandLoading/DemandPbrtScene/CMakeLists.txt:34 (embed_cuda)


CMake Error at CMake/embed_cuda.cmake:108 (set_property):
  CUDA_OPTIX_COMPILATION property is not supported by NVIDIA compiler version
  11.5.119.
Call Stack (most recent call first):
  examples/DemandLoading/DemandTextureViewer/CMakeLists.txt:39 (embed_cuda)


CMake Error at CMake/embed_cuda.cmake:108 (set_property):
  CUDA_OPTIX_COMPILATION property is not supported by NVIDIA compiler version
  11.5.119.
Call Stack (most recent call first):
  examples/DemandLoading/RayCones/CMakeLists.txt:35 (embed_cuda)


CMake Error at CMake/embed_cuda.cmake:108 (set_property):
  CUDA_OPTIX_COMPILATION property is not supported by NVIDIA compiler version
  11.5.119.
Call Stack (most recent call first):
  examples/DemandLoading/Texture/CMakeLists.txt:38 (embed_cuda)


CMake Error at CMake/embed_cuda.cmake:108 (set_property):
  CUDA_OPTIX_COMPILATION property is not supported by NVIDIA compiler version
  11.5.119.
Call Stack (most recent call first):
  examples/DemandLoading/TexturePainting/CMakeLists.txt:35 (embed_cuda)


CMake Error at CMake/embed_cuda.cmake:108 (set_property):
  CUDA_OPTIX_COMPILATION property is not supported by NVIDIA compiler version
  11.5.119.
Call Stack (most recent call first):
  examples/DemandLoading/TextureVariantViewer/CMakeLists.txt:35 (embed_cuda)


CMake Error at CMake/embed_cuda.cmake:108 (set_property):
  CUDA_OPTIX_COMPILATION property is not supported by NVIDIA compiler version
  11.5.119.
Call Stack (most recent call first):
  examples/DemandLoading/UdimTextureViewer/CMakeLists.txt:39 (embed_cuda)


Configuring incomplete, errors occurred!

CMakeCache.txt (52.4 KB)

Ok optix 8.0 only compiles with CUDA 12.0